[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Nokia 6021 + IRDA: workin from time to time.

From: Pavel Khmelinsky
Subject: Re: Nokia 6021 + IRDA: workin from time to time.
Date: Thu, 13 Apr 2006 22:19:49 +0400

Thanks for attention Angelo.

If that's like you said so i could restart IR on my phone and it's should solve my problem but it didn't.

On 13.04.2006, at 22:16, Angelo Chu wrote:

Dear Pavel,

I'm using Nokia 8210 with IrDA.The situation is exactly the same as you.Your situation arised because if you have no data transfer with the phone within designated minutes (refer to your phone's manual),the connection will be terminated by your phone.As a result,the message from the gnokii will show "Expecting... and some kind of error" because the connection is broken.I thought of a work- around and write a script to continously sending data to the phone with a designated interval say like 30 secs but ultimately,it failed.It started smoothly,it generated same error as you after 20 or so minutes.I can't figure out.As a result,I use my other phone with cable to solve my problem and save my time.

I have been searching the mailing list and google all the time,I found zero message or reply regarding this problem.So,I suggest you should find a better solution instead of figuring out why.That's my 10 cents. :-)

Best regards,

On 4/14/06, Pavel Khmelinsky <address@hidden> wrote: Hello!

I have Nokia 6021 and USB-Irda adapter which actually USB<->COM<- >IRDA adapter
as i think.
It's using pl2303 module and attaching to /dev/ttyUSB0 when i plug it.

So for setup my irda I am using commands:
modprobe ma600-sir
modprobe irtty-sir
irattach /dev/ttyUSB0 -d ma600 -s

# lsmod | grep ir
rtty_sir               7936  2
ma600_sir               3968  1
sir_dev                18620  2 irtty_sir,ma600_sir
irda                  129720  4 ma600_sir,sir_dev
crc_ccitt               3072  1 irda

then i starting gnokii. And some times it's work. But for sure only once. If it's workin and i stop the program next time when i start it it will report:
Serial device: opening device /dev/ttyUSB0
Default: Nokia 6021     df2d
connect: No route to host
Couldn't open PHONET device: No route to host
Error in link initialisation: 1
GSM/FBUS init failed! (Unknown model?). Quitting.
Serial device: closing device

And after reboot it could work and could not.
When it's not workin i tried
echo 115200 > /proc/sys/net/irda/max_baud_rate
Didn't helped.

I also tried remove all modules and use this:
modprobe irda
modprobe irtty-sir
irattach /dev/ttyUSB0 -s
In that case  lsmod looks like
# lsmod | grep ir
irtty_sir               7936  2
sir_dev                18620  1 irtty_sir
irda                  129720  1 sir_dev
crc_ccitt               3072  1 irda

In irdadump i am seening my devices but i didn't ever have luck with gnokii with
such modules.

Most strange thing is that sometimes it work. It' ever show me my address book
but segfaulted on the middle of it.

Any ideas where to search for? Any troubleshooting guide?


gnokii-users mailing list

gnokii-users mailing list

Pavel S. Khmelinsky <address@hidden>
System Administrator,
ISP Yauza Telecom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]