[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fxscintilla-users] Cygwin configure does not work

From: David Hisel
Subject: Re: [fxscintilla-users] Cygwin configure does not work
Date: Sat, 09 Nov 2002 12:27:10 -0600

 % ./configure --with-foxinclude=/usr/include --with-foxlib=/usr/lib

this didn't help, the same error occurred.

Actually, it seems like a linker problem...it can't find the function 'fxfindfox' that you put in as a test. There is no function in the Fox libs that is named fxfindfox and there is no function body in your code snippet used for the test.


At 02:58 PM 11/7/2002, Gilles Filippini wrote:
David Hisel wrote:
> When I run ./configure it stops and says that there is no FOX library.
> I compiled your program:
>  --------------------------------------
> #include <fox/fxver.h>
> #include <stdio.h>
> int main(int argc, char** argv) {
>  printf("Using FOX version %d.%d.%d\n",
> }
>  ----------------------------
> ...and here are the results:
> $ gcc -o conftest -I/usr/include -L/usr/lib -lFOX conftest.c
> cc1: warning: changing search order for system directory "/usr/include"
> cc1: warning:   as it has already been specified as a non-system directory
> $ ./conftest.exe
> Using FOX version 1.0.26
> I have attached the config.log for you.
> I installed FOX in the cygwin directories /usr/include and /usr/lib.
> Please let me know what I can do to fix the configure script.
> Regards,
> .dave.

It seems my conf scripts aren't suited for Fox being installed in
prefix=/usr :(
Here is a workaround:

 % ./configure --with-foxinclude=/usr/include --with-foxlib=/usr/lib

Please let me know the result.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]