[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Fenfire-dev] Libvob: Modifications in base classes.

From: Matti Katila
Subject: Re: [Fenfire-dev] Libvob: Modifications in base classes.
Date: Mon, 8 Mar 2004 08:31:02 +0200 (EET)

On Sun, 7 Mar 2004, Benja Fallenstein wrote:
>>>later, if we like this option we can enclapsuate those to vs itself so 
>>>then it will look like:
>>>vs.animate() or  vs.switch()
>> Actually vs.switchVS() because switch is a statement in java language.
> Actually, I'd prefer
>     update()
>     updateNoAnimation()
> because
> - these tell WindowAnimation to regenerate the vobscene, which should be 
> said in the method names IMO

Update tells to regenerate vs? how? I mean, update and rerender sound 
very same method names to me.

> - it should be clear from the names that they do similar things

There's no need for that because WindowAnimation is basicly 3 methods, 
i.e., rerender, animate and switchVS. There is no need to say in method 
name that the two last are similar. Why? Because to do anything with 
libvob, you need to understand the mechanism how it works and if user 
understands how animation is done between 2 vobscenes, the user 
understands also the difference between these 3 methods.

> - animating is the normal case,

Not true, it depends of the application. I think in fenpdf rerender is 
the most common case.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]