[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Fenfire-dev] Libvob: Modifications in base classes.

From: Benja Fallenstein
Subject: Re: [Fenfire-dev] Libvob: Modifications in base classes.
Date: Sun, 07 Mar 2004 20:31:07 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122 Debian/1.6-1

Matti Katila wrote:
On Sat, 28 Feb 2004, Matti Katila wrote:

later, if we like this option we can enclapsuate those to vs itself so then it will look like:

vs.animate() or  vs.switch()

Actually vs.switchVS() because switch is a statement in java language.

Actually, I'd prefer



- these tell WindowAnimation to regenerate the vobscene, which should be said in the method names IMO
- it should be clear from the names that they do similar things
- animating is the normal case, so it seems reasonable to say just update() for that and have updateNoAnimation() have the longer name.

- Benja

reply via email to

[Prev in Thread] Current Thread [Next in Thread]