[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: org-agenda on Mac M1

From: Henrik Frisk
Subject: Re: org-agenda on Mac M1
Date: Thu, 16 Mar 2023 16:46:55 +0100

Den tors 16 mars 2023 kl 14:58 skrev Ruijie Yu <ruijie@netyu.xyz>:
Henrik Frisk <frisk.h@gmail.com> writes:

> When I run org-agenda I get the sub menu but if I hit 'a' emacs hangs,
> though I can get it back if I hit C-g.  [...]
> I have no experience in debugging, but I tried to run debug-on-error
> with org-agenda and I got the following, which is not so helpful (to
> me):
> [...]
> Anyone else has a suggestion on a next step here?

What happens when you run `M-x toggle-debug-on-quit RET' right after you
run `emacs -Q', and do your usual steps to reproduce the issue?  That
might provide a more detailed backtrace for investigation.

Well, with emacs -Q there hasn't been a problem so far, so it's in my configuration or in one of the agenda files, but it appears to happen on random: taking out one agenda file may make it work, but then after a restart it doesn't work, etc.
In addition, what version of Emacs and of org are you using?  Posting
the results of these two commands would help a lot:
Ah yes, sorry!
- `M-: emacs-repository-version RET'
That evaluates to nil. M-x emacs-version is GNU Emacs 28.2 (build 1, aarch64-apple-darwin21.6.0, Carbon Version 165 AppKit 2113.6) of 2023-02-12
- `M-x org-version RET'

reply via email to

[Prev in Thread] Current Thread [Next in Thread]