[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

org-agenda on Mac M1

From: Henrik Frisk
Subject: org-agenda on Mac M1
Date: Thu, 16 Mar 2023 14:31:51 +0100


I have rrecently had to move from Linux to MacOS and setting up on an M1 computer I have run inte to ann issue I can't figure out. When I run org-agenda I get the sub menu but if I hit 'a' emacs hangs, though I can get it back if I hit C-g. Without my init file it works. I have gone through all my claendar files, adding the one at a time and I have gone through my init file using this method:

1. Remove everything except the org-agenda stuff: org-agenda works as expected
2. Adding one piece of the config file at a time: org-agenda works after eache addition
3. After a emacs restart org agenda fails.

I have no experience in debugging, but I tried to run debug-on-error with org-agenda and I got the following, which is not so helpful (to me):

* org-agenda(nil)
  funcall-interactively(org-agenda nil)
  call-interactively(org-agenda record nil)
  command-execute(org-agenda record)
  execute-extended-command(nil "org-agenda" "org-agenda")
  funcall-interactively(execute-extended-command nil "org-agenda" "org-agenda")
  call-interactively(execute-extended-command nil nil)

Anyone else has a suggestion on a next step here?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]