discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GWorkspace and new ABI


From: David Chisnall
Subject: Re: GWorkspace and new ABI
Date: Mon, 14 Oct 2019 11:22:39 +0100
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

I'm not sure if it's the same problem, but I've had some issues in CI that I can't reproduce locally for gworkspace FreeBSD packages. Either the core or the gworkspace extras appears not to be passing the correct runtime flags to the compiler, so I get an error when they are linked.

David

On 14/10/2019 10:01, Johannes Brakensiek wrote:
Hi Ivan,

thank you very much for your help! As I did not do any debugging of
GNUstep/ObjC before this really helps.

Am 11.10.19 um 16:06 schrieb Ivan Vučica:
1. Try using gdb to run GWorkspace (I'd guess gdb
/usr/GNUstep/Applications/GWorkspace.app/GWorkspace should do the
trick). Then when it inevitably calls abort(), you'll be dropped into
gdb's CLI. Type 'bt' to get the backtrace which will tell you which
library tried to access a bad protocol.

It still won't tell you which protocol is that, but it's a start.

2. If you haven't done things like that before and don't have
time/will to try it now, and if you previously had GNUstep on the
machine, I'd try to nuke /usr/GNUstep and possibly
~/GNUstep/Library/Libraries, then /etc/GNUstep.conf. Then reinstall
from scratch.

As I had installed 1.9 runtime to test if it works (it does) I tried
both. After reinstallation the error remains.

This is what gdb reports - not really helpful I think:

Starting program: /usr/GNUstep/Local/Tools/GWorkspace
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Unknown protocol version
Program received signal SIGABRT, Aborted.
__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
50      ../sysdeps/unix/sysv/linux/raise.c: File not found.

I think the last error is raised after SIGABRT, so probably not the
cause of the issue?

So if anybody has a further hint I'll try again or otherwise just stick
to 1.9 for a while.

Johannes


_______________________________________________
Discuss-gnustep mailing list
address@hidden
https://lists.gnu.org/mailman/listinfo/discuss-gnustep




reply via email to

[Prev in Thread] Current Thread [Next in Thread]