discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Linker error while trying to use arc


From: Ivan Vučica
Subject: Re: Linker error while trying to use arc
Date: Wed, 1 May 2019 17:12:20 +0100

It was indeed a strange autocorrect.

Thanks, this is very informative!

On Wed 1 May 2019 at 17:11, David Chisnall <address@hidden> wrote:
On 01/05/2019 13:06, Ivan Vučica wrote:
>
>
> On Wed 1 May 2019 at 09:03, David Chisnall <address@hidden
> <mailto:address@hidden>> wrote:
>
>     On 30/04/2019 18:12, Ivan Vučica wrote:
>      > I don't think you installed libobjc2. Its .so is called libobjc2.so*.
>
>     This is not true.  It is intended to be a drop-in replacement for the
>     old gcc runtime, so uses the same name for the binary.
>
>
> Oops. Apologies for handing out wrong advice. In my defense, there’s
> nonzero amount of google results for “libobjc2.so” :)
>
> Given it’s (to my knowledge) not compatible with GCD runtime, and thus
> not actually a drop in replacement, was that a good idea?

I presume GCD is a typo.  It is compatible with the GCC runtime, and
(still, though not if you disable old ABI compat in CMake) able to work
with code compiled with GCC.

I tried making the test suite build with gcc a little while ago, but it
turns out that about 80% of the tests check functionality that GCC
doesn't support, so I never committed it.  The tests that did compile
with GCC still worked.

If GCD is not a typo and you mean libdispatch: libobjc2 imports the
hooks that libdispatch exports for ARC memory management.

> I think incompatibility is why I always assumed it’s not named libobjc.so.

Most users of the first libobjc2 releases were using it with gcc.

David
--
Sent from Gmail Mobile

reply via email to

[Prev in Thread] Current Thread [Next in Thread]