[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems compiling base: configure aborts testing libffi [RHEL6]

From: Frederico Muñoz
Subject: Problems compiling base: configure aborts testing libffi [RHEL6]
Date: Thu, 5 Apr 2012 10:56:15 +0100


I'm trying to get my GNUstep environment up in a new installation and
I've reached an obstacle early in the process that I can't seem to
clear; before opening a bug report (which I will do, of course, if
warranted) I would just like to make sure I'm not missing something
quite obvious.

RHEL 6.2  Desktop (x86_64)
gcc 4.4.6
glibc 2.12
GNUstep svc co from yesterday, 4-April-2012

The included libffi version is 3.0.5-3.2 (below the minimum
recommended), and when I just use ./configure I get

checking ffi.h usability... yes
checking ffi.h presence... yes
checking for ffi.h... yes
checking callback.h usability... no
checking callback.h presence... no
checking for callback.h... no
checking for forwarding callback in runtime... yes
checking FFI library usage... configure: error: The ffi library
(libffi) does not appear to be working.  Perhaps it's missing or you
need a more recent version.  Version 3.0.9 or later should work, and
you can find a link to it n the list of packages for download at

The config.log contains:

configure:24985: checking FFI library usage
configure:25018: gcc -o conftest -g -O2
-I/opt/GNUstep/Local/Library/Headers -I/usr/lib64/libffi-3.0.
5/include    -L/opt/GNUstep/System/Library/Libraries
-L/opt/GNUstep/Local/Library/Libraries conftest.c -lffi   -lnsl -lrt
-ldl  -lpthread
-lz >&5
configure:25021: $? = 0
configure:25027: ./conftest
./configure: line 25028: 17656 Aborted                 ./conftest$ac_exeext
configure:25030: $? = 134
configure: program exited with status 134
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define GNUSTEP_TARGET_MAKEFILES "/opt/GNUstep/System/Library/Makefiles"

No problem, it's probably the libffi version - or so I thought. I got
libffi-3.0.9, configure && make && make install was uneventful. Tried
to compile base with:

./configure  --with-ffi-include=/opt/libffi-3.0.9/lib/libffi-3.0.9/include

... and got the same result as above, same Abort message, same line
number. I've even removed the original libffi-devel form the system
just to make sure configure was catching the right one (and it is,
since without the --with-ffi flags it complains about missing

I've searched around the list and overall, couldn't find something
that I found similar (some hits in kFreeBSD builds but that seem of a
different nature). Is this sort of problem something known and with a
neasy fix, something knows and reported, or something peculiar to my
system? If so I will open a bug report.

Thank you in advance,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]