discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems compiling base: configure aborts testing libffi [RHEL6]


From: Frederico Muñoz
Subject: Re: Problems compiling base: configure aborts testing libffi [RHEL6]
Date: Thu, 5 Apr 2012 15:25:27 +0100

Hello,

Thank you for you answer, highly appreciate it.

2012/4/5 Nerijus Baliunas <address@hidden>:
> On Thu, 5 Apr 2012 10:56:15 +0100 Frederico Muñoz <address@hidden> wrote:
>
>> No problem, it's probably the libffi version - or so I thought. I got
>> libffi-3.0.9, configure && make && make install was uneventful.
>
> I recommend to make uninstall your manually compiled version and to just 
> install
> libffi-devel package (yum install libffi-devel).

Yes, perhaps I wasn't clear: that was what I had in place when it gave
the error, I had libffi and libffi-devel installed from the RHEL6
repos; since the version if not the one recommended I assumed that the
error could be because of that - and apparently wasn't.

> If it still does not work, get libffi*.src.rpm
> from Fedora 16 sources and do rpmbuild --rebuild libffi*.src.rpm, then install
> the built packages.

This means updating a "base" package, something I'm not overly eager
to do since it could break existing programs, including the ones I
need for work. I have yum configured to disallow the replacement of
base packages because of this (even if I have a very limited number of
third-party repos, I used to add more like rpmforge and sometimes the
result was... mixed).

This is why I compiled it by hand and installed it in /opt, and
removed the -devel package (and not the libs since that would mean
uninstalling half the system). It's my impression that configure
should work, regardless of libffi being present via the package
manager or a source tarball.

Best regards,

Frederico



reply via email to

[Prev in Thread] Current Thread [Next in Thread]