[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem building GNUstep on openSUSE 10.2

From: Richard Stonehouse
Subject: Re: Problem building GNUstep on openSUSE 10.2
Date: Thu, 15 Feb 2007 10:53:24 +0000
User-agent: Mutt/1.5.13 (2006-08-11)

Thanks! Problem now solved (I think), as indicated below.

On Wed, Feb 14, 2007 at 11:22:25AM +0100, Fred Kiefer wrote:
> Richard Stonehouse schrieb:
> > I'm trying to build GNUstep on openSUSE 10.2 and have hit a problem.
> > I wonder if anyone can throw light on it - or, alternatively, whether
> > anyone has successfully built GNUstep on openSUSE 10.2 and, if so,
> > how?
> > 
> > The problem is that the plmerge program fails with a buffer overflow
> > and dumps out a Backtrace and Memory map - sample at:
> > <URL:http://www.rstonehouse.co.uk/testcase/plmerge-results.txt>
> > 
> > The fault lies in plmerge, as built, and not with the data it is
> > being given. It is reproducible with a trivial test case.
> > 
> > In SuSE 9.3, plmerge - built from the same gnustep-base source -
> > works OK. The main differences between 9.3 and 10.2, that seem to be
> > potentially relevant, are:
> > 
> >   - 10.2 has gcc version 4.1.2_20061115 (I think this is a
> >     pre-release; Novell seem keen on living at the 'bleeding edge'),
> >     whereas 9.3 used 3.3.5; and
> > 
> >   - 10.2 has libffi (however the problem occurs irrespective of
> >     whether I use libffi or ffcall).
> > 
> > The problem is not the result of building under rpmbuild; it occurs
> > even if I build by the orthodox configure/make process.

This proved to be inaccurate - see below.

> > Any help on this would be very welcome!
> > 
> I am using GNUstep on OpenSUSE 10.2 and it works fine for me. I know
> this comment wont help you in any way :-(

Actually, it was helpful in eliminating one of the wrong trees I was
barking up.

> Form the little information that is in your backtrace I would expect
> that the problem you are seeing is related to the contents of your
> GNUstep.conf file. This would mean that any other GNUstep tool or
> application would fail as well. Could you please confirm this?

The GNUstep.conf file was the same as that generated under SuSE 9.3.

The tools defaults, gclose, gdnc, gnustep_sndd, gspath, make_services,
make_strings, set_show_service and xmlparse failed.

openapp, opentools, plparse and sfparse worked.

> Next step could be to start anew with a clean build of GNUstep, deleting
> everything that was there before.

This was the clue -  a clean configure/make produced a working
plmerge, whereas the rpmbuild route continued to give the failure.

However, rpmbuild produced a working plmerge when I took out the
variable setting: CFLAGS="${RPM_OPT_FLAGS}" from the spec file.

RPM_OPT_FLAGS has changed from
  '-O2 -g -march=i586 -mcpu=i686 -fmessage-length=0' (SuSE 9.3)
  '-O2 -g -m32 -march=i586 -mtune=i686 -fmessage-length=0
-D_FORTIFY_SOURCE=2' (openSUSE 10.2)
so I wonder if one of these flags may have been the cause of the

Anyway, thanks very much for pointing me in the right direction.
    Richard Stonehouse

reply via email to

[Prev in Thread] Current Thread [Next in Thread]