[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnustep on macos x panther

From: Bill Northcott
Subject: Re: gnustep on macos x panther
Date: Tue, 19 Apr 2005 09:18:32 +1000

On 19/04/2005, at 2:46 AM, Secret Guy wrote:
I've installed or am trying to install gnustep. I used instructions I
read here:


However, I was unable to install libffi. I tried gcc-3.3.2, 3.3.5,
3.4.0, 3.4.1, 3.4.2 and 3.4.3, and tried pyobjc/libffi-src with some
of those and all either didn't support objc or failed to build ffi.

Though the README.Darwin in gnustep-make-1.10.0 says libffi is
required, it also later says what to do if "you decided not to install
libffi". So, I took that path.

It is really simple to build libffi on Panther. Just get Apple gcc-4.0 code from the main gcc cvs by using one of the apple-ppc-40XX tags.

Have a look at the build_gcc script. You can find where it sets up the configure options for gcc. All you need to do is move libffi from the list of libraries that only build if gcj is enabled to the default list a few lines higher up. Then follow the Apple build instructions. You will need a recent version of cctools. The one in the just released Darwin 7.9 sources should work.

The same trick can be used to build the GNU runtime as part of the Apple compiler.

This should all work even better on Tiger because there the gcc_select script understands gcc-4.0 and gcc-4.0 is the default compiler.

Bill Northcott

reply via email to

[Prev in Thread] Current Thread [Next in Thread]