discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Where Is 'GSConfig.h'?


From: René Berber
Subject: Re: Where Is 'GSConfig.h'?
Date: Mon, 08 Sep 2003 11:40:00 -0500

On 2003-09-07 16:42:46 -0500 Philip Mötteli <address@hidden> wrote:

> Am Sonntag, 07.09.03, um 20:31 Uhr (Europe/Zurich) schrieb David Ayers:
>> Philip Mötteli wrote:
[snip]
> 
> configure says also something else:
> 
> checking whether objc really works... no
> I don't seem to be able to use your Objective-C compiler to produce
> working binaries!  Please check your Objective-C compiler installation.
> If you are using gcc-3.x make sure that your compiler's libgcc_s and libobjc
> can be found by the dynamic linker - usually that requires you to play
> with LD_LIBRARY_PATH or /etc/ld.so.conf.

Do you have more than one gcc installed?

Please check on a terminal "which gcc" and "gcc -print-search-dirs"

> I can't find 'ld.so.conf', so I tried finding libgcc_s and libobjc:

There's also this way: "gcc -print-libgcc-file-name"

> usr/lib/libobjc.A.dylib
> /usr/lib/libobjc.A_profile.dylib
> /usr/lib/libobjc.dylib
> /usr/lib/libobjc_profile.A.dylib
> /usr/lib/libobjc_profile.dylib
> /usr/lib/gcc/darwin/3.3/libgcc_static.a

This type of library only work with Apple's gcc (and NeXT's if you were using 
Openstep / NextStep).  That's the reason I asked if you have more than one gcc 
installed, GNU's gcc will not use these libraries AFAIK.

> 
> Then I put that into LD_LIBRARY_PATH:
> 
> % echo $LD_LIBRARY_PATH
> /usr/lib/gcc/darwin/3.3:/usr/lib

There's also the -B option in gcc (see gcc --help) but it should work about the 
same.

> 
> I also tried it with:
> 
> :/usr/lib/gcc/darwin/3.3:/usr/lib
> 
> With no effect. All this had no influence on configure.
> 
> 
>> But this may depend on a successfully installed gnustep-make package
> 
> I think, I have that installed.
> 
> 
>> and a sourceing '/usr/GNUstep/System/Makefiles/GNUstep.[c]sh'
> 
> At least, I can make the sourcing of the shell.

You can check that the sourcing worked by looking at the environment changes 
(printenv | grep GNU) LD_LIBRARY_PATH is one of the changes.
[snip]
-- 
René Berber





reply via email to

[Prev in Thread] Current Thread [Next in Thread]