[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Where Is 'GSConfig.h'?

From: Philip Mötteli
Subject: Re: Where Is 'GSConfig.h'?
Date: Sun, 7 Sep 2003 23:42:46 +0200

Am Sonntag, 07.09.03, um 20:31 Uhr (Europe/Zurich) schrieb David Ayers:
Philip Mötteli wrote:
I try to build Gnustep-Base on MOSX 10.2.6. I try to use the ProjectBuilder file available in the directory 'macosx'. After having adapted a lot of (search)paths, it still complains:

This directory was contributed by a while back. But it doesn't seem to be actively maintained.

No, but if I succeed, this could be done by me for a good period of time. If I succeed…

Well, as you suspected, 'GSConfig.h' is supposed to get generated by './configure' from 'Headers/Additions/GNUstepBase/GSConfig.h.in'.

configure says also something else:

checking whether objc really works... no
I don't seem to be able to use your Objective-C compiler to produce
working binaries!  Please check your Objective-C compiler installation.
If you are using gcc-3.x make sure that your compiler's libgcc_s and libobjc
can be found by the dynamic linker - usually that requires you to play
with LD_LIBRARY_PATH or /etc/ld.so.conf.

I can't find 'ld.so.conf', so I tried finding libgcc_s and libobjc:


Then I put that into LD_LIBRARY_PATH:


I also tried it with:


With no effect. All this had no influence on configure.

But this may depend on a successfully installed gnustep-make package

I think, I have that installed.

and a sourceing '/usr/GNUstep/System/Makefiles/GNUstep.[c]sh'

At least, I can make the sourcing of the shell.

Maybe someone using -base with the macosx extensions can give you more pointers on how build it with ProjectBuilder.

I know only one such person: Stéphane Corthésy. I already wrote him.

Otherwise you could try manually creating the file from the template.

This will probably be complicated…

It would be interesting to know if you can get -base to work with the Apple ObjC Runtime. Last time someone tried they ran into trouble as the libffi/ffcall hooks of the GNU ObjC Runtime are not available, but required for NSInvocation magic. You might have to find a way to disable DO. When using the standard -make / -base building machinery. You can './configure' with '--disable-do', but I have no idea how this may fit into ProjectBuilder build scheme.

Well, as I thought so far, is that all the classes, already available in Apple's Foundation library should be used. So Apple's DOs and NSInvocation should be used. This Gnustep-Base, I'm trying to compile, is just a very reduced subset of Gnustep-Base – kind of only the Gnustep-Base-Additions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]