discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: iconv...


From: James Fletemeyer
Subject: Re: iconv...
Date: Wed, 30 May 2001 07:56:52 -0500

"Chris B. Vetter" wrote:

> On Wed, 23 May 2001 22:01:44 -0600
> Adam Fedor <address@hidden> wrote:
> > "Chris B. Vetter" wrote:
> > > > Do I still need to include giconv.h if I have libgiconv?
> > > Yes, libgiconv installs /usr/local/include/giconv.h - to avoid
> > > confusion with libiconv (w/o "G"), which installs
> > > /usr/local/include/iconv.h.
> > OK. Unicode.m now includes giconv if we're using libgiconv. Please let
> > me know if that works.
>
> Yes, it compiles smoothly (CVS check out, last Friday; FreeBSD-4.3;
> gcc 2.95.3; libxml2 and -lgiconv).
>
> However, is it just me, my setup, or does libgnustep-xgps only work
> properly on Window Maker?
> I've tried several applications, eg Gorm and GWorkspace, and they all
> seg-fault'd if started with any window manager I've tried, except
> Window Maker (0.65.0, installed from Ports).
> There, they work fine, as long as you don't close windows using ESC. In
> that case, all windows, including the menu(s) will minimize...
>
> libgnustep-xdps works fine on all window managers (but looks kinda ugly).
>
> Oh, I'm not sure if it's important or needed, but neither configure, for
> xgps and xdps, seems to "find" X11/extensions/XShm.h, though it does exist
> and is supported by X11.

I have tried several snapshots from 5/17 - 5/29
and all examples segfault on startup.

I am running Debian potato upgraded to
Progeny1.0 (newton).
gcc = 2.95.2
no ffcall
no xml2
no openssl
no gnustep_objc

The combination of base 1.0, make 1.0, gui 0.6.8 and xgps 0.6.8
works fine with this set-up. I had been using Mandrake 7.2
with early April snapshots and they worked well.
Mandrake had 2.95.3 I think. I use enlightenment but switching
to windowmaker 0.6.2 did not help.

I notice that xgps builds by default as a bundle. I
would like to try building as a library. It's just not
obvious to me how to go about this. Have I missed a
simple configure option ?

jim




reply via email to

[Prev in Thread] Current Thread [Next in Thread]