[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ImportError

From: Mario Moran
Subject: Re: ImportError
Date: Mon, 1 Nov 2021 13:57:47 -0600

So when I run the command to remove gnuradio I did not get an error message. Instead it asked me if I wanted to continue and I said yes and it finished. I believe it did succeed. For the command, 'dpkg -l | grep gnuradio' here is the output:

rc  gnuradio                                     amd64        GNU Radio Software Radio Toolkit
ii  libgnuradio-analog3.8.1:amd64                       amd64        gnuradio analog functions
ii  libgnuradio-analog3.8.3:amd64                amd64        gnuradio analog functions
ii  libgnuradio-audio3.8.1:amd64                        amd64        gnuradio audio functions
ii  libgnuradio-audio3.8.3:amd64                 amd64        gnuradio audio functions
ii  libgnuradio-blocks3.8.1:amd64                       amd64        gnuradio blocks functions
ii  libgnuradio-blocks3.8.3:amd64                amd64        gnuradio blocks functions
ii  libgnuradio-channels3.8.1:amd64                     amd64        gnuradio channels functions
ii  libgnuradio-channels3.8.3:amd64              amd64        gnuradio channels functions
ii  libgnuradio-digital3.8.1:amd64                      amd64        gnuradio digital communications functions
ii  libgnuradio-digital3.8.3:amd64               amd64        gnuradio digital communications functions
ii  libgnuradio-dtv3.8.1:amd64                          amd64        gnuradio digital TV signal processing blocks
ii  libgnuradio-dtv3.8.3:amd64                   amd64        gnuradio digital TV signal processing blocks
ii  libgnuradio-fec3.8.1:amd64                          amd64        gnuradio forward error correction support
ii  libgnuradio-fec3.8.3:amd64                   amd64        gnuradio forward error correction support
ii  libgnuradio-fft3.8.1:amd64                          amd64        gnuradio fast Fourier transform functions
ii  libgnuradio-fft3.8.3:amd64                   amd64        gnuradio fast Fourier transform functions
ii  libgnuradio-filter3.8.1:amd64                       amd64        gnuradio filter functions
ii  libgnuradio-filter3.8.3:amd64                amd64        gnuradio filter functions
ii  libgnuradio-pmt3.8.1:amd64                          amd64        gnuradio pmt container library
ii  libgnuradio-pmt3.8.3:amd64                   amd64        gnuradio pmt container library
ii  libgnuradio-qtgui3.8.1:amd64                        amd64        gnuradio Qt graphical user interface functions
ii  libgnuradio-qtgui3.8.3:amd64                 amd64        gnuradio Qt graphical user interface functions
ii  libgnuradio-runtime3.8.1:amd64                      amd64        gnuradio core runtime
ii  libgnuradio-runtime3.8.3:amd64               amd64        gnuradio core runtime
ii  libgnuradio-trellis3.8.1:amd64                      amd64        gnuradio trellis modulation functions
ii  libgnuradio-trellis3.8.3:amd64               amd64        gnuradio trellis modulation functions
ii  libgnuradio-uhd3.8.1:amd64                          amd64        gnuradio universal hardware driver functions
ii  libgnuradio-uhd3.8.3:amd64                   amd64        gnuradio universal hardware driver functions
ii  libgnuradio-video-sdl3.8.1:amd64                    amd64        gnuradio video functions
ii  libgnuradio-video-sdl3.8.3:amd64             amd64        gnuradio video functions
ii  libgnuradio-vocoder3.8.1:amd64                      amd64        gnuradio vocoder functions
ii  libgnuradio-vocoder3.8.3:amd64               amd64        gnuradio vocoder functions
ii  libgnuradio-wavelet3.8.1:amd64                      amd64        gnuradio wavelet functions
ii  libgnuradio-wavelet3.8.3:amd64               amd64        gnuradio wavelet functions
ii  libgnuradio-zeromq3.8.1:amd64                       amd64        gnuradio zeromq functions
ii  libgnuradio-zeromq3.8.3:amd64                amd64        gnuradio zeromq functions

What does this mean? 

So I used the command ' find /usr -name *gnuradio*' and there was none there so I followed your instructions and removed the directory and recreated it and installed it. There was an error with the cmake, it said: 
CMake Error at cmake_install.cmake:41 (file):
  file INSTALL cannot set permissions on
  Operation not permitted.

So I used sudo make install instead and it completed it without fail. 

The reason why I had to was when I was trying to figure out how to fix this I thought maybe the prefix was incorrect so I find Gnuradio that was not installed pybombs and used the command of cmake but instead of prefix.3.8 I placed Would it be ok to remove that one or would that correct problems? 

I start gnuradio companion through the terminal using this: 
source ~/prefix-3.8/setup_env.sh

Thank you for all of your help so far in this. Sorry for all of the questions I have. 

On Mon, Nov 1, 2021 at 1:34 PM Vasil Velichkov <vvvelichkov@gmail.com> wrote:
Hi Mario,

On 01/11/2021 19.50, Mario Moran wrote:
> I see, when I downloaded gnuradio from pybombs I must have not realized
> that I had gnuradio so I installed it again with a different command. I
> have tried to removed with sudo apt-get remove gnuradio

So what was the result? Did the `sudo apt-get remove gnuradio` succeed? Do you still have libgnuradio-* packages installed on your system? Provide the output of

    dpkg -l | grep gnuradio

> but the command
> 'find /home/mario -name libgnuradio-tutorial.so.1.0.0git' I still got the
> same results as before I used sudo apt-get remove gnuradio.

This is OK. This library was not install by gnuradio's package so you can't remove it by removing the gnuradio package. So after you've removed all gnuradio packages you need to check if there are any leftovers by running

   find /usr -name *gnuradio*

and if there is none then you need to do a clean rebuild of your OOT and then reinstall

   source /home/mariom/prefix-3.8/setup_env.sh
   cd /home/mariom/gr-tutorial/
   rm -rf build/
   mkdir build
   cd build
   cmake -DCMAKE_INSTALL_PREFIX=/home/mariom/prefix-3.8/ ..
   make install

> The results
> were:
> /home/mariom/gr-tutorial/build/lib/libgnuradio-tutorial.so.1.0.0git
> /home/mariom/prefix-3.8/lib/x86_64-linux-gnu/libgnuradio-tutorial.so.1.0.0git
> /home/mariom/prefix-

So you have two prefixes - `prefix-3.8` and `prefix-`. This is OK as long as you are careful where you install things. You should not mix two prefixes and source their setup_env.sh scripts at the same time in the same terminal.

> I then tried to rerun the flowgraph and I am still getting the same error.
> I do wonder, would it be easier to reset the whole thing.

How do you start gnuradio-companion? If you start it from your prefix then in your terminal you first need to source the setup_env.sh file or run `pybombs run gnuradio-cmpanion`


reply via email to

[Prev in Thread] Current Thread [Next in Thread]