[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ImportError

From: Mario Moran
Subject: Re: ImportError
Date: Mon, 1 Nov 2021 11:50:04 -0600

I see, when I downloaded gnuradio from pybombs I must have not realized that I had gnuradio so I installed it again with a different command. I have tried to removed with sudo apt-get remove gnuradio but the command 'find /home/mario -name libgnuradio-tutorial.so.1.0.0git' I still got the same results as before I used sudo apt-get remove gnuradio. The results were: 
I then tried to rerun the flowgraph and I am still getting the same error. I do wonder, would it be easier to reset the whole thing. 

On Mon, Nov 1, 2021 at 3:48 AM Vasil Velichkov <vvvelichkov@gmail.com> wrote:
Hi Mario,

On 01/11/2021 03.46, Mario Moran wrote:
> Since I installed it with pybombs, I used the command "$ cmake
> -DCMAKE_INSTALL_PREFIX=~/prefix-3.8 ../ # should be the configured PyBOMBS
> target" and I used it in the build directory.

On 01/11/2021 03.01, Mario Moran wrote:
> The Gnuradio Companion I am running is Gnu Radio Companion and I
> installed it using Pybombs.

You have two gnuradio versions installed on your system - the first one installed using pybombs (in /home/mariom/prefix-3.8/).

> libgnuradio-runtime.so.3.8.3 => /lib/x86_64-linux-gnu/libgnuradio-runtime.so.3.8.3 (0x00007fb4a6bd4000)
> libgnuradio-pmt.so.3.8.3 => /lib/x86_64-linux-gnu/libgnuradio-pmt.so.3.8.3 (0x00007fb4a6b68000)

And a second one (in /lib/ and /usr/lib) most probably installed from the Ubuntu's repository. The `ldd -r ...` commands shows that the tutorial's OOT module has been build for the system wide installation (in /lib/) but you have installed it in the pybombs' prefix by specifying -DCMAKE_INSTALL_PREFIX.

Having two versions of gnuradio installed at the same time (especially if one is in /lib/ or /usr/lib/) is not recommended unless you are very experienced as you can easily mix the two and have some very difficult to debug problems. My recommendation is to choose one version and remove the other.

> I believe I installed it there, but im not fully
> confident in it. Is there a way to check that

You can use

    find /home/mario -name libgnuradio-tutorial.so.1.0.0git
    find /usr/ -name libgnuradio-tutorial.so.1.0.0git

to check/find where the library has been installed.

> im not sure if that is
> the LD_LIBRARY_PATH. I'm very new to this, I've been learning all of this
> from stretch.

In you prefix (/home/mariom/prefix-3.8/) there is a shell script called setup_env.sh. It exports some environment variables that are needed by python and library loader to find python modules and libraries in your prefix. In can either load this script manually

  source /home/mariom/prefix-3.8/setup_env.sh

or open a new bash/shell session using pybombs

   pybombs run bash

You can also source this file in ~/.profile to load it automatically.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]