[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Python OOT module not showing up in GRC

From: Barry Duggan
Subject: Re: Python OOT module not showing up in GRC
Date: Sat, 18 Jul 2020 07:43:07 -0500
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:68.0) Gecko/20100101 Thunderbird/68.10.0


Note the first statement in the tutorial: "NOTE: This tutorial has been deprecated in GR 3.8."

We chose not to update that one as the material is covered in our other tutorials which we have updated. See our revised https://wiki.gnuradio.org/index.php/Tutorials

Barry Duggan KV4FV

On Fri, 17 Jul 2020 15:33:02 -0700, Roman A Sandler wrote:


I have followed Section 3.2 in the tutorial https://wiki.gnuradio.org/index.php/Guided_Tutorial_GNU_Radio_in_Python to setup an OOT python block in GRC.

I followed the instructions on a Linux machine running GNURadio 3.7 and it worked exactly as described.

I then ran the tutorial on an NVIDIA Xavier Linux machine w/ GNURadio 3.8 and all the steps seemed to work. The QA test worked in python, and `cmake; make; sudo make install; sudo ldconfig` all ran without any errors. However, when I open GRC, I cannot see the block.

I am wondering if this tutorial is not up-to-date w/ GNURadio 3.8 or if maybe there is something weird about the Xavier that is causing the bug.

Let me know,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]