[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Python OOT module not showing up in GRC

From: Ron Economos
Subject: Re: Python OOT module not showing up in GRC
Date: Fri, 17 Jul 2020 17:34:38 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0

GNU Radio 3.8 uses YAML instead of XML for the files in the grc directory. You can convert your .xml files to .yaml files with the command:

gr_modtool update --complete


On 7/17/20 15:33, Roman A Sandler wrote:

I have followed Section 3.2 in the tutorial https://wiki.gnuradio.org/index.php/Guided_Tutorial_GNU_Radio_in_Python to setup an OOT python block in GRC. 

I followed the instructions on a Linux machine running GNURadio 3.7 and it worked exactly as described. 

I then ran the tutorial on an NVIDIA Xavier Linux machine w/ GNURadio 3.8 and all the steps seemed to work. The QA test worked in python, and `cmake; make; sudo make install; sudo ldconfig` all ran without any errors. However, when I open GRC, I cannot see the block. 

I am wondering if this tutorial is not up-to-date w/ GNURadio 3.8 or if maybe there is something weird about the Xavier that is causing the bug. 

Let me know, 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]