[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] two versions of uhd installed?

From: Ali Dormiani
Subject: Re: [Discuss-gnuradio] two versions of uhd installed?
Date: Thu, 10 Jan 2019 11:34:57 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

The repos are outdated. I ran into the same problem when first getting started too.

You need to compile both UHD and GNUradio from source to get the versions you want.

Ettus has a great (very thorough) guide on how to do this.


*tip: instead of 'make' you can type 'make -j 2' in order to greatly speed you the compiling process. (only if you have 6 gigs of ram or more)

Feel free to post in this thread again if you get an error.

On 01/10/2019 11:09 AM, Achilleas Anastasopoulos wrote:
Hi all and happy new year,

It is not clear to me if this question is a usrp or gnuradio related so I send it to both lists. Apologies for the duplication.

I have installed a clean version of gnuradio to an ubuntu box
from repos with apt-get.

I then installed from the ettus site the uhd files using:
"Using binaries provided by Ettus Research":
sudo add-apt-repository ppa:ettusresearch/uhd
sudo apt-get update
sudo apt-get install libuhd-dev libuhd003 uhd-host

After trying to communicate with my newly bought X310 
I got some error messages about incompatibility of FPGA images that
I fixed with appropriate downloading/burning the new images to FPGA.

Now commands like uhd_find_devices and uhd_usrp_probe work perfectly, eg,

address@hidden:~$ uhd_find_devices 
[INFO] [UHD] linux; GNU C++ version 7.3.0; Boost_106501; UHD_3.13.0.1-release
-- UHD Device 0
Device Address:
    serial: 311D131
    fpga: HG
    product: X310
    type: x300

telling me that I am using UHD_3.13.0.1-release
PROBLEM: however when I run a simple uhd example (eg, uhd_const_wave.py)
I get the following error:

address@hidden:/tmp$ ./uhd_const_wave.py 
Warning: failed to XInitThreads()
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

-- X300 initialization sequence...
-- Determining maximum frame size... 1472 bytes.
-- Setup basic communication...
Traceback (most recent call last):
  File "./uhd_const_wave.py", line 203, in <module>
  File "./uhd_const_wave.py", line 191, in main
    tb = top_block_cls(samp_rate=options.samp_rate, freq=options.freq, gain=options.gain, address=options.address)
  File "./uhd_const_wave.py", line 98, in __init__
  File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/__init__.py", line 122, in constructor_interceptor
    return old_constructor(*args)
  File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py", line 3012, in make
    return _uhd_swig.usrp_sink_make(*args)
RuntimeError: RuntimeError: Expected FPGA compatibility number 33, but got 35:
The FPGA image on your device is not compatible with this host code build.
Download the appropriate FPGA images for this version of UHD.
Please run:


Then burn a new image to the on-board flash storage of your
USRP X3xx device using the image loader utility. Use this command:

"/usr/bin/uhd_image_loader" --args="type=x300,addr="

For more information, refer to the UHD manual:



So it seems that it is using a different uhd library (UHD_003.010.003.000-0-unknown) than the one I installed from ettus...
How can I fix this?



Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]