[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem trying to get DDD to debug a simple assembly language program

From: Rich Loda
Subject: Problem trying to get DDD to debug a simple assembly language program
Date: Wed, 03 Apr 2013 16:11:47 -0400

I have a Zareason 64 bit laptop running Ubuntu Linux 12.10 64 bit. Have been 
reading an "Assembly language step by step" book and have been attempting to 
use ddd
to  debug. Obtained ddd from Ubuntu software center download.
Have compiled: nasm -f elf64 -g -F dwarf junk.asm
Linked: ld -o junk junk.o
The program from terminal successfully prints "Eat at Joe's!" as it should.

However, when I try to load it into ddd  the program hangs and I get a 
continuous hourglass. The code "displays", but I can't set breakpoints or do 
anything else. 
The only way I can get it to load is from the terminal, i.e ____$ddd junk.

When I do the above. I note that the terminal lists several Warnings, e.g 
Warning: Cannot convert string "-*helvetica-medium-r .....and Warning: could 
not load font....."
I believe leaving the cursor hung up also.

I've tried the unzipped file from the book site (called "eatsyscall"), and also 
retyping in only the executable asm (no comments) to no avail.

I can "debug" the (working) program with gdb from the terminal. Can set breaks, 
list, inspect registers as one should.

I've tried web sites and reading the ddd manual, but am at a loss. I suspect 
I'm doing something silly, but would appreciate any feedback. Could it be ddd 
doesn't handle 64 bit code? Note the same
thing happens, even if I use the 32-bit book version that was already compiled 
when unzipped?!

Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]