[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem installing ddd-3.3.11

From: Andrew Gaylard
Subject: Re: Problem installing ddd-3.3.11
Date: Fri, 01 Sep 2006 20:18:35 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060503

Juan Martin Strupeni wrote:

>       My name is Juan Martin. I'm having a problem installing ddd.
>When I run the configure script:
>DesaDGRAFIP:/home/dgr/Debugger/ddd-3.3.11 # ./configure
>it ends with line:
>configure: error: Cannot find termcap compatible library.
>When I run
>DesaDGRAFIP:/home/dgr/Debugger/ddd-3.3.11 # make
>it returns:
>make: *** No targets specified and no makefile found.  Stop.
>I downloaded termcap-1.3.1.
>DesaDGRAFIP:/home/dgr/Debugger/termcap-1.3.1 # ./configure
>loading cache ./config.cache
>checking for gcc... (cached) gcc
>checking whether we are using GNU C... (cached) yes
>checking whether gcc accepts -g... (cached) yes
>checking for ranlib... (cached) ranlib
>checking for a BSD compatible install... (cached) /usr/bin/install -c
>checking how to run the C preprocessor... (cached) gcc -E
>checking for string.h... (cached) yes
>checking for unistd.h... (cached) yes
>checking whether cross-compiling... (cached) no
>checking for ANSI C header files... (cached) yes
>creating ./config.status
>creating Makefile
>Running make
>DesaDGRAFIP:/home/dgr/Debugger/termcap-1.3.1 # make
>makeinfo ./termcap.texi --output=termcap.info
>make: makeinfo: Command not found
>make: *** [termcap.info] Error 127
>I attach both ddd-3.3.11/config.log and termcap-1.3.1/config.log in case
>this may help.
>Thanks to anyone in advance.
OK, first off:

When you report a problem, it *really* helps if you mention your CPU,
and OS.
But digging into your logs, I see that you're using x86/Linux/Suse.

The reason that ddd won't build is that DDD can't find a terminal library.
The reason that termcap doesn't build is that makeinfo isn't found.
makeinfo is part of texinfo (if I remember correctly).
I suspect that texinfo will in turn require TeX.

But it may be simpler to install ncurses instead of termcap + texinfo + TeX.

Give that a try,

PS: it surprises me that your Suse installation doesn't already have

reply via email to

[Prev in Thread] Current Thread [Next in Thread]