cjk-list
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cjk] Installation Cyberbit as PostScript font failed


From: amigolang
Subject: Re: [cjk] Installation Cyberbit as PostScript font failed
Date: Thu, 01 Jun 2017 13:23:30 +0200

Dear Werner,

thank you again for your email!

I subscribed to the list, before I wrote my first email to you, but only now, with your hints, I found out how to see the messages. Thank you!

Warning: This email is quite long! If you are in a hurry, only read the "conclusion" at the bottom!

With your hints and others, I had read before in the internet, today I started a new try to install a Noto Serif font (= SourceHan Serif). I did the following:

First under Ubuntu 17.04 with a full texlive Installation (I later need a working texlive installation under Windows 7 -- but there fontforge doesn't work):

Download Noto Serif CJK TC. 
Inside the Zip-File are fonts in different densities, for my first try I choose the file NotoSerifCJKtcMedium.otf, renamed it to nose.otf and stored it in a newly established working directory  ~/fonts/NotoSerif.

Then I did in a terminal:

rm -rf ~/.texmf-var/fonts/pk

sudo mkdir -p /usr/local/share/fonts/opentype/google/nose 

sudo mv ~/fonts/NotoSerif/nose.otf  /usr/local/share/fonts/opentype/google/nose

sudo ln -s /usr/local/share/fonts/opentype/google/nose/nose.otf  ~/fonts/NotoSerif/nose.otf

cd ~/fonts/NotoSerif

sudo cp /usr/share/latex-cjk-common/utils/subfonts/subfonts.pe .

The point at  the end of the last line is essential, as it points to the current directory. I am not shure, whether the files subfonts.pe and the later mentioned Unicode.sfd where part of the texlive full installation, or whether I downloaded them from the internet in an earlier attempt.

Now I could start in the terminal:

sudo fontforge -script subfonts.pe nose.otf nose /usr/share/texlive/texmf-dist/fonts/sfd/ttf2pk/Unicode.sfd

That took about eight minutes on my Thinkpad W530 with i7-3840QM 2.8GHz  with 4 cores/8 threads and produced 359 *.afm, *.enc, *.pfb and *.tfm each. Then I went  on with

sudo su

The following lines I ended with shift-return each, only the last lines I ended with a normal return:

for i in *.pfb
do
echo "$(basename $i .pfb) $(basename $i .pfb) <$i"\
>>nose.map
done

Then, to return from the superuser state:

exit

I could now under Linux have put the files into the appropriate directories, but as an installation under Windows is my aim, I now went on under Windows 7, 64 bit (also with an existing full texlive installation):

To the file C:\texlive\texmf-local\web2c\updmap.cfg I added the line: 

Map nose.map

Had the file not existed, I would have generated it. Then I created the file C:\texlive\texmf-local\tex\latex\nose\c70nose.fd with the content (I overtook that from Cyberbit without understanding, just exchanging "Cyberbit" by "nose"):

ProvidesFile{c70nose.fd}
% character set: Unicode U+0080 - U+FFFD
% font encoding: Unicode

\DeclareFontFamily {C70}{nose}{\hyphenchar address@hidden
\DeclareFontShape{C70}{nose}{m}{n}{<-> CJK * nose}{}
\DeclareFontShape {C70}{nose}{bx}{n}{<-> CJKB * nose}{\CJKbold}

\endinput


Now I copied the files created under Ubuntu (everything goes to C:\texlive\texmf-local, which is my $TEXMFLOCAL$, I only mention the subdirectories, which should have been the same for continuing the Ubuntu installation, only with a different $TEXMFLOCAL$):

*.afm: \fonts\afm\google\nose\
*.tfm: \fonts\tfm\google\nose\
*.pfb: \fonts\type1\google\nose\
*.enc: \fonts\enc\dvips\nose\
nose.otf: \fonts\opentype\google\nose\
nose.map: \fonts\map\dvips\nose\
Unicode.sfd: \fonts\sfd\ttf2pk\

Then I ran in a cmd-shell with administrator privileges (would be the same under Ubuntu as well)

texhash 
updmap-sys

With that I hoped to be ready...

I created the little file attached to this email as a sort of minimum working example: It contains the most critical parts of my text, though it might not cover all problems. And, contrary to my real world file, I can compile it with both  normal LaTeX or PDFLaTeX.

First I tried with PDFLaTeX. The run stops with "0 errors, 0 warnings". But if I look into the log file, it says "Missing character: There is no ^^S in font nose66!". And in case I don't listen carefully, it says it even twice... uhm...

Then I tried with LaTeX. The same (why it doesn't work at all on another machine, I don't know yet...).

So now I tried my real world file. LaTeX ended with "0 errors, 135 warnings, 578 overfull boxes, 1074 underful boxes", which sounds quite normal to me. 

Looking into the log file now reveals a few more missing characters:

xA8 in nose58 (the sign is inverted white on black)
^^S in nose66
N in nose67
xF3 in pplr9t (also inverted, obviously not our problem, as well as some more, not mentioned here).

I can't look at the dvi file, "Failed to make tmpps1.pbm by the command C:\texlive\2014\tlpkg\tlgs\bin\gswin32c.exe @tmp $.@@@" (ooohps, that still points to my old texlive installation), but that may be normal, I never use the dvi file, so I can't say. In the end I see one instead of more than 1500 pages -- completely blank...

dvips generates a PostScript file and doesn't seem to complain. Looking into it with gsview shows the Chinese insertations, I haven't really controlled yet, which signs are present, but I already noticed some missing. So apart from those the dvi file itself should be ok as well, even if the vieler has  a problem...

Converting to PDF via gswin64 also works.

Conclusion:
The installation of the font as such seems to have worked quite alright (after some minor problems, which I could solve on my own).

But I still have missing characters: xA8 (inverted) in nose58, ^^S in nose66 and N in nose67.

So my remaining question is: Is there any font, with which I could hope to get the missing signs as well? May possibly the Regular variant include them (as I used Medium)?

In every case: Thank you very much for your help! Without it it would have taken me weeks longer to get so far -- if I hadn't given up completely...

Thorsten









Von meinem Samsung Gerät gesendet.


-------- Urspr√ľngliche Nachricht --------
Von: Werner LEMBERG <address@hidden>
Datum: 31.05.17 11:36 (GMT+01:00)
An: address@hidden
Cc: address@hidden, address@hidden
Betreff: Re: AW: Re: [cjk] Installation Cyberbit as PostScript font failed



> I admit, I am completely unexperienced concerning the usage of a
> mailing list.  Up to now I got two replies directly from you.  But
> as I see from the comment in your last email, there are others
> answering me as well.  How can I get access to their answers as
> well?

You should subscribe to `cjk-list', see

  https://lists.nongnu.org/mailman/listinfo/cjk-list

On this page you can also see a link to the archive, which collects
all mails sent to address@hidden'.

> Although I put quite some effort in getting Cyberbit running, I am a
> bit relieved, that that not seems to be the right way, as I learned
> from your and other's comments, that that is not a very nice font.

Well, cyberbit was a very early try to create a pan-Unicode font, but
it has many deficiencies.  In particular, the used shapes for the
various scripts don't harmonize at all.  Modern OpenType fonts can do
much more, especially for CJK languages: Depending on the environment,
different glyph shapes should be used, cf.

  https://en.wikipedia.org/wiki/Han_unification

This is something cyberbit doesn't take care at all (but SourceHan
does).


    Werner

Attachment: sample-nose.tex
Description: null


reply via email to

[Prev in Thread] Current Thread [Next in Thread]