[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[cjk] Installation Cyberbit as PostScript font failed

From: amigolang
Subject: [cjk] Installation Cyberbit as PostScript font failed
Date: Tue, 30 May 2017 14:46:52 +0200

I am completely new to the list, it is the first time, that I seek advice in the internet and English is not my mother's tongue -- so please help me, if I do something wrong...

I have a LaTeX text I started writing in 2003. Over the years it has grown to some 1500 pages with many pictures using the psfrag package. My OS is Windows 7, 64 bit.

Recently I have done an attempt, fruitless up to now, to change over to PDFLaTeX  (with the aim later to change to XeLaTeX/LuaLaTeX), so in the moment I have to stick to good old LaTeX with PostScript Type 1 fonts (the engineer says: Never change a running system...).

I am trying since more than three weeks now to use the CJKutf8 package for introducing some chinese characters from somewhere in the internet (unfortunately I am not capable of any chinese myself -- so I have to copy and paste and for that purpose to use UTF8 encoding and changed my encoding appropriately).

As no PostScript UTF8 font comes with the CJK package (no complain, I am happy, that there is such a package!),  I tried to do with the Cyberbit.ttf font downloaded from http://ftp.netscape.com/pub/communicator/extras/fonts/windows/Cyberbit.ZIP, some  extra files and 165 *.tfm and *.enc files downloaded from www.ece.uci.edu/~chou/unicode/cyberbit-{tfm,enc}.tgz. I managed to get a little test text working with PDFLaTeX. But that still was not PostScript Type 1...

I completely failed with getting 
"ttf2pfb cyberbit.ttf -o cyberbit.pfb"
working. It keeps complaining about my OS not being 32 bit, what of course is the case. So no *.pfb file...

After a while of search for help in the internet I found out about a "New way" working with fontforge. But as fontforge only works under Linux, I installed a virtual machine with Ubuntu  17.04 and afterwords TeXLive  (complete).

I was very happy, when after a while and adapting some paths I got through. There was only a very little drop of bitterness, as I only got 155 *.tfm and *.enc files each instead of 165. The files with numbers 34 through 3d were missing...

I copied all files to the corresponding paths in my Windows installation, ran mktexlsr and updmap-sys. When after that my chinese implants worked, I was even happier...

...till the moment,  when, after a few more chinese implants, the machine complained about the missing cyberb38.* files...

I would prefer to get the "New way" running. But I have no idea, why the 10 files are missing and more, what I can do about it. 

And now I am giving up, I need help: Does anybody have any advice for me?

Von meinem Samsung Gerät gesendet.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]