[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cjk] texlive svn write access Fw: Re: revisiting ttf2tfm and dvipdf

From: Hin-Tak Leung
Subject: Re: [cjk] texlive svn write access Fw: Re: revisiting ttf2tfm and dvipdfmx
Date: Wed, 17 Jul 2013 15:34:43 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17.1

Peter Breitenlohner wrote:> On Wed, 17 Jul 2013, Hin-Tak Leung wrote:
>>>> - the post table issue is in pdftex/dvipdfmx/xdvidpdfmx (see below). Very
>>>>   old fonts use 00000000 but really should be treated as 00030000 (which
>>>>   is basically no post table).
> Hi Hin-Tak,
> I'd rather say:
>        ...................... but really should have 00030000 (no post table).

> Does 'all' mean pdftex/luatex/xetex or as well dvipdfmx/xdvidpdfmx?

Similiar logic are in dvipdfmx, xdvipdfmx, pdftex, luatex. I only tried
dvipdfmx and pdftex.

>> Not everybody should be required to use a hex editor to modify a "not-needed"
>> byte in some 15-yr-old fonts to use them.
> I don't agree at all.  Everybody should either throw away these broken font
> files or get them fixed (with a hex editor or otherwise).

That's probably why fewer and fewer people are using TeX. CJK fonts of unusual typefaces are difficult to come by. Not everybody have the knowledge/know-hows to change these fonts in the necessary way (and minimally). You are trying to punish users for wanting to do in TeX what they can do with some "easier" typesetting systems.

That's texlive shipped with fedora. It says 20130608 r30832 over all.

that is the FreeType 1 version and 'ttf2tfm -help' should say 'Version 1.5'.
Is this 32bit or 64bit?


Perhaps 10 years ago you have used a 32bit version and now a 64bit one?

That's possible. It is a bug, in any case.

You should get the current TeX Live svn, build the FreeType 2 Version, and
repeat the test with that one.  I have just tried that for 32bit with no

It isn't really my intention to spend more time on this than necessary. I think this exchange is discouraging enough I don't want to spend time going off in that direction.

This is definitely inside libttf, not much we can do about.

"can't" or "won't"?


(gdb) run  open-more/mikachanALL.ttc -f 1 -q -w address@hidden@
Starting program: /usr/bin/ttf2tfm open-more/mikachanALL.ttc -f 1 -q -w

Program received signal SIGFPE, Arithmetic exception.
0x0000000000407443 in readttf (address@hidden, quiet=True,
   at ../../../texk/ttf2pk/ttfaux.c:262
262        fnt->xheight = properties.os2->sxHeight * 1000 / fnt->units_per_em;
(gdb) bt
#0  0x0000000000407443 in readttf (address@hidden, quiet=True,
   at ../../../texk/ttf2pk/ttfaux.c:262
#1  0x0000000000401c86 in main (argc=<optimized out>, argv=<optimized out>) at
(gdb) print fnt->units_per_em
$1 = 0
(gdb) print properties.os2->sxHeight
$2 = 6896

Either bad logic or invalid font data.  Hard to say without mikachanALL.ttc.

I mentioned this font is on sourceforge. It still is (or a version of it). Mine has a date stamp of "Jun 8 2004", the "current" downloadable version in
seems to be 8 months younger. Perhaps you can have a go at that. The issue was intermittent here, and ftdump (from freetype does not show problem with EM size, so the trace was strange.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]