[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Chicken on Windows 10 - Was: [ANN] CHICKEN 5.0.0 rel

From: Jörg F . Wittenberger
Subject: Re: [Chicken-users] Chicken on Windows 10 - Was: [ANN] CHICKEN 5.0.0 release candidate 2 available
Date: 17 Sep 2018 15:05:58 +0200

Thanks Kristian,

problem solved:

Operating system: MINGW64_NT-10.0
Hardware platform: x86-64
C Compiler: gcc.exe (Rev1, Built by MSYS2 project) 8.2.0
Installation works?: yes
Tests work?: yes
Installation of eggs works?: yes

Surprisingly the pathname issue went away. I guess this is already documented in the README "disguised" as "Cygwin will not be able to find the chicken shared libraries until Windows is rebooted".

Thanks again for all the work which went into CHICKEN.


On Sep 17 2018, Kristian Lein-Mathisen wrote:

Hi Jorg,

If I'm not mistaken, the Readme mentions says that you have to specify a
PREFIX for Windows builds. I'm guilty os trying the same "shortcut". And
obs: use forward slashes and include the drive letter and colon!

I don't know what's happing with the absolute-pathname trouble - I never
ran into that issue. Could the generated absolute pathnames be wrong due to
the same issue?


On Sat, Sep 15, 2018, 15:26 Jörg F. Wittenberger <
address@hidden> wrote:

Hi Kristian,

I don't have the Windows machine close. I'm not perfectly sure, but I
should not have specify a PREFIX at all. My intention was first and
foremost to test that a default installation done by a windows novice
hints from the wiki works.

Surprisingly this went well up to the compile.

The first issue I ran in could likely go away using your suggestion.

The second I'm afraid will not. The generated build scripts just do not work on my system. As I'm a windows novice using msys2 first time, I'm cautious to actually assign the blame. My guess is that the windows cmd.exe should eventually execute the build scripts. If that's true than it does not work because, wait for it, my cmd.exe does not accept the command when it is given with path. It wants to do the lookup itself. At least that's what it looks alike. I changed the "@echo off" to "@echo on" and it perfectly works until there is this '/usr/local/bin/chicken-do' ... if I replace this with just chicken-do it starts... just to break down when it tries to execute csc the same way.

Anything I could do to track this down?



On Sep 14 2018, Kristian Lein-Mathisen wrote:

>Hi Joerg,
> I was trying C5rc1 on win10 i few weeks ago and had to do some > tweaking to get it working og msys2 (which was surprisingly > comfortable to use).
> I also had a problem with chicken-install not downloading anything at > first. The symptom became clearer when I did chicken-install > -update-db. I realised I wasn't using an absolute path for PREFIX when > invoking
> Doing something like make PLATFORM=mingw-msys PREFIX=C:/c5/ solved the
> issue, maybe you've run into the same problem?
> I never tried to change the defaults, so this may be completely > unrelated. K.
>On Wed, Sep 12, 2018, 16:15 Jörg F. Wittenberger <
>address@hidden> wrote:
>> Hi all,
>> who is running chicken on Windows 10 here? How do you manage? I'm not
>> sold to msys; I just tried first time and failed miserably.
>> Any idea how to do a better setup (for chicken 5 release candidates)
>> welcome.
>> Maybe we can fix the support for msys2 nevertheless;
>> So far I found two issues on Windows 10 + msys2 + mingw-w64:
>> 1. chicken-install does not pick up the contents of setup.defaults by
>> itself.
>>    Workaround: chicken-install -defaults
>> /usr/local/share/chicken/setup.defaults
>>    -- which is saying: give the defaults from the installation on the
>> command line again.
>>    -- This does the download and generates the build scripts
>> (*.build.bat)
>> 2. Using "start" to open a window running cmd.exe I found that I can
>> not call chicken-do using the full path. As it is in the PATH variable
>> tried to copy the invocation line with only the path leading to
>> chicken-do removed.
>>    This leads to:
>> /usr/local/bin/csc -host -D compiling-extension -J -s -setup-mode >> -I C:\msys64\home\... ...
>>    creating subprocess failed
>> Best
>> /Jörg
>> On Sep 12 2018, Jörg F. Wittenberger wrote:
>> >On Sun, Sep 09, 2018 at 02:30:12PM +0200, Peter Bex wrote:
>> >> If you can, please let us know the following information about the
>> >> environment on which you test the RC:
>> >
>> >Operating system: MINGW64_NT-10.0
>> >Hardware platform: x86-64
>> >C Compiler: gcc.exe (Rev1, Built by MSYS2 project) 8.2.0
>> >Installation works?: yes
>> >Tests work?: yes
>> >Installation of eggs works?: no
>> >
>> >Installation of eggs fails like this (for all eggs; immediately):
>> >
>> >$ chicken-install.exe pastiche
>> >
>> >Error: extension or version not found: "pastiche"
>> _______________________________________________
>> Chicken-users mailing list
>> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]