[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] [ANN] CHICKEN 5.0.0 release candidate 2 available

From: querent
Subject: [Chicken-users] [ANN] CHICKEN 5.0.0 release candidate 2 available
Date: Wed, 19 Sep 2018 23:42:35 +1200

Well, this is weird.  I tried several different things, nothing worked, then suddenly it compiled fine!
I have also managed to chicken-install r7rs, apparently successfully, although I haven't tried to use it yet.  make check hasn't worked, though, see below.
The last thing I did was re-download the tarball, because I deleted it accidentally.  The only thing I can think of is that I've been using an incomplete download 'till now, but I'm not sure how convincing that is.  The files you mentioned existed, and I didn't get any other errors.  
I have been using Kristian's invocation.
I don't get very far with a make check:

$ make PLATFORM=android PREFIX=$HOME/c5/ check
cd tests; sh
======================================== repository search path ... 69: ../csi: Permission denied
make: *** [rules.make:972: check] Error 126
I can execute $HOME/c5/bin/csi fine.
A few things to note about how I got here:
*) I was always extracting the tarball on my device.
*) the timestamp for the files you suggested I look at were always within a second of one another
*) ls --full-time only seems to give times to one second precision
*) 'touch'ing eval.c didn't help
*) termux uses busybox's tar.  I installed the tar package.  This didn't seem to help either.
I might wind everything back and start again from download onwards just to check.  
I might try on an old PowerMac in the weekend, too.
18.09.2018, 23:37, "Peter Bex" <address@hidden>:

On Tue, Sep 18, 2018 at 11:20:08PM +1200, querent wrote:

 Better late than never?


    Operating system: android 7.0
    Hardware platform: aarch64
    C Compiler: gcc 7.3.0
    Installation works?: no
    Tests work?: N/A
    Installation of eggs works?: N/A
    I was following Alexander Shendl's instructions to build in termux
    (chicken 4.12, but I thought it might work for 5.0.0 too, perhaps
    mistakenly) and this is what I get:
    $ TMPDIR=$HOME/tmp make C_COMPILER=clang PREFIX=$HOME/chickens/5.0.0
    PLATFORM=android install
    [all the echoing snipped]
    clang -fno-strict-aliasing -fwrapv -DHAVE_CHICKEN_CONFIG_H
    -DC_ENABLE_PTABLES -c -Os -fomit-frame-pointer -DC_BUILDING_LIBCHICKEN
    library.c -o library-static.o -I. -I./
    chicken eval.scm -optimize-level 2 -include-path . -include-path ./
    -inline -ignore-repository -feature chicken-bootstrap -no-warnings
    -specialize -consult-types-file ./types.db -explicit-use -no-trace
    -output-file eval.c \
    -emit-import-library chicken.eval \
    -emit-import-library chicken.load
    make: chicken: Command not found
    make: *** [rules.make:788: eval.c] Error 127
    perhaps there's something I'm not doing right here?

Could you check the timestamp of eval.c is newer than all of the
following Scheme files?

- eval.scm
- chicken.blob.import.scm
- chicken.condition.import.scm
- chicken.foreign.import.scm
- chicken.internal.import.scm
- chicken.keyword.import.scm
- chicken.platform.import.scm

Please check them after untarring and after the failed build. Maybe
something is touching those files. Also, did you untar on the device,
or copy the files? If the latter, you'd have to copy with preservation
of time stamps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]