[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-xorriso] grub-mkrescue does not boot on older Macs as USB stick

From: Andrei Borzenkov
Subject: [Bug-xorriso] grub-mkrescue does not boot on older Macs as USB stick
Date: Tue, 22 Dec 2015 23:02:38 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.4.0

I tested stock grub-mkrescue on MacBook 3,1 (late 2007, Core 2 Duo) and
iMac 9.1 (2009, same CPU) as USB stick. Neither boots; moreover,
inserting USB stick when boot manager is shown hangs system (it stops
reacting to mouse/keyboard); if stick is inserted during boot it never
gets as far as even showing boot manager.

Alexander reported something similar for 2007 Macs.

Stick is not detected even when inserted under OS X. MacBook runs 10.7
and reports that USB stick is not readable and suggests to iniitialize
it; iMac runs 10.9 and simply ignores it (may be I do not know where to

I tried two different USB and one of them boots fine here on Dell
Latitude E5450 as EFI so I do not think both of them are defect. Of
course, they are not of finest quality ...

Same image as CD boots (I tried only MacBook but do not have reasons to
think that iMac will not boot). It presents three choices - two EFI and
one Windows. Windows ends up in presenting 1, 2 menu (without any
additional explanation) and not accepting any input. This is known
problem with legacy El Torito boot. First EFI boots; checking $cmdpath
it boots from HFS+ partition. Second EFI does not boot and falls through
to default boot order. When I try to chainload bootx64.efi manually (I
have dual OS X/openSUSE on it) it actually boots fine. I /think/ it
tries to load \EFI\Boot\boot.efi which is 32 bit only. I need to test
with removed boot.efi and with fat image.

I do not know if mkrescue image ever booted as USB on Mac. Alexander
says it does on modern Mac; anyone ever tried it on earlier models?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]