[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: trying to use gpm without X, having a little trouble

From: Patrick
Subject: Re: trying to use gpm without X, having a little trouble
Date: Mon, 20 Oct 2014 10:43:48 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0

On 14-10-20 05:14 AM, Thomas Dickey wrote:
On Fri, Oct 17, 2014 at 01:53:03PM -0400, Patrick wrote:
I have mouse support enabled in my program and it's working great
under X. I took X down with ctrl-alt F1 and tried again with gpm
running it didn't work.

I tried to recompile ncurses with a flag to specifically enable gpm:

./configure --with-gpm --enable-ext-colors --enable-ext-mouse --enable-widec

but it doesn't seem to work.

Should it have worked? I can just use the gpm calls but it would be
nice to use it through ncurses.
I just tested with Debian/7, and it works for me.  Did you install the
gpm development package for (whatever system you are using)?

Hi Thomas

Thanks for taking time out of your day to test this. I am on Mint and it seems that gpm is broken here(probably lots of other stuff too!).

BTW gpm does not look to be in good shape. The maintainer has stated he has lost interest in the project and says it is being dropped by many distros.

I am just doing some xcb test right now and I have posted to freedesktop for help. If I came up with a little piece of code that would track mouse positions by columns and rows under X, would it be possible to merge the code at some point ?

Perhaps there could be a configure option to enable mouse-under-X. This would eliminate the problem with mouse co-ordinates not being reported past 213 for people who are running under X. The project could still default to gpm and the 213 limit.

I am also trying to red the gpm source. It's very small at under 2K lines but it's tricky and I am struggling.

Thanks again-Patrick

reply via email to

[Prev in Thread] Current Thread [Next in Thread]