[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'build-use-chroot = true' leads to 'ERROR: In procedure system*: No

From: Nikita Karetnikov
Subject: Re: 'build-use-chroot = true' leads to 'ERROR: In procedure system*: No such file or directory'
Date: Sun, 16 Dec 2012 18:08:16 +0300


I'm getting the same error with the following command:

# ./pre-inst-env guix-daemon --build-users-group=nixbld -C 0

> Is /bin/sh a symlink?  If it is, its target has to be in one of the
> directories listed in ‘build-chroot-dirs’.

Yes. It points to bash, which is in '/bin'.

> An option is to replace /bin/sh by the statically-linked Bash that’s in
> distro/packages/bootstrap/*-linux/bash

Same error.

> Another one, which I think we’ll do, is to change gnu-build-system.scm
> to either run (system* "/path/to/our/bash" "./configure" ...), or call
> ‘patch-shebangs’ on ‘configure’.

I don't know how to change the former, but I've tried the latter.


(phases set-paths unpack patch patch-shebangs configure build check
        install strip)

AFAICT, it changed the build order, but the same error appeared

> But more importantly, /bin/sh is likely to be a dynamically-linked
> executable, linked against stuff from /lib, which is not in
> ‘build-chroot-dirs’.  Thus, it won’t run in the chroot.

The following works.


build-users-group = nixbld
build-use-chroot = true
build-chroot-dirs = /dev /proc /bin /lib

Does it make sense? Will it help to catch impurities?

'attr' failed with the following backtrace, but 'hello' and 'wget' succeeded.

make[1]: Leaving directory
starting phase `check'
In ice-9/boot-9.scm:
 157: 12 [catch #t #<catch-closure 97f5d20> ...]
In unknown file:
   ?: 11 [apply-smob/1 #<catch-closure 97f5d20>]
In ice-9/boot-9.scm:
  63: 10 [call-with-prompt prompt0 ...]
In ice-9/eval.scm:
 414: 9 [eval # #]
In ice-9/boot-9.scm:
2131: 8 [save-module-excursion #<procedure 9799180 at
ice-9/boot-9.scm:3660:3 ()>]
3665: 7 [#<procedure 9799180 at ice-9/boot-9.scm:3660:3 ()>]
1456: 6 [%start-stack load-stack ...]
1461: 5 [#<procedure 980d8a0 ()>]
In unknown file:
   ?: 4 [primitive-load
In ice-9/eval.scm:
 375: 3 [eval # ()]
In srfi/srfi-1.scm:
 830: 2 [every1 #<procedure 998b4b0 at
(expr)> ...]
In ice-9/eval.scm:
 375: 1 [eval # #]
In unknown file:
   ?: 0 [system* "test/run"]

ERROR: In procedure system*:
ERROR: In procedure system*: No such file or directory
note: keeping build directory
builder for `/nix/store/jihisz016g3yjdrfgls0zn718cz0rzxm-attr-2.4.46.drv'
failed with exit code 1
@ build-failed /nix/store/jihisz016g3yjdrfgls0zn718cz0rzxm-attr-2.4.46.drv
/nix/store/zpzl9z209wnrfi4f90rq7k0lzz7q7ixy-attr-2.4.46 1 builder for
`/nix/store/jihisz016g3yjdrfgls0zn718cz0rzxm-attr-2.4.46.drv' failed
with exit code 1
error: build failed: build of
`/nix/store/jihisz016g3yjdrfgls0zn718cz0rzxm-attr-2.4.46.drv' failed

Is this a different issue?

('attr' builds fine on x86_64. [1])


[1] http://hydra.nixos.org/job/gnu/guix-distro-master/attr-2.4.46

reply via email to

[Prev in Thread] Current Thread [Next in Thread]