[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'build-use-chroot = true' leads to 'ERROR: In procedure system*: No

From: Nikita Karetnikov
Subject: Re: 'build-use-chroot = true' leads to 'ERROR: In procedure system*: No such file or directory'
Date: Sun, 16 Dec 2012 22:09:58 +0300

> OK.  Can you copy/paste the actual error, because I’m losing track.  ;-)

I was talking about this error. [1]

> Again that’s because /bin/sh is either missing from the chroot, or it’s
> there but it’s a symlink whose target is missing, or it’s a
> dynamically-linked binary and some of its requirements are missing.

> Just try ‘ldd /bin/sh’.  Everything listed there should be in the chroot.

Yeah, got it.

First I tried to use 'nix-worker --daemon'.


build-users-group = nixbld
build-use-chroot = true
build-chroot-dirs = /dev /proc /bin

I copied our 'bash' to '/bin/sh', ran './pre-inst-env
guix-build -K attr', and it succeeded.

Then I tried
'./pre-inst-env guix-daemon --build-users-group=nixbld -C 0 &'.

This error [1] appeared again.


[1] https://lists.gnu.org/archive/html/bug-guix/2012-12/msg00093.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]