[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gsl] finite deprecated in OSX, iOS

From: Jeff E Mandel
Subject: Re: [Bug-gsl] finite deprecated in OSX, iOS
Date: Mon, 03 Feb 2014 21:16:08 -0500

FYI, autoconf is not supplied by Xcode 5 (or 4.5); it has to be installed, such 
as I have done with MacPorts:

$ xcrun --find autoconf

$autoconf --version
autoconf (GNU Autoconf) 2.69

I tried this:

$ autoconf -W all
configure.ac:95: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
configure.ac:95: You should run autoupdate.
aclocal.m4:129: AC_PROG_LIBTOOL is expanded from...
configure.ac:95: the top level
configure.ac:107: warning: The macro `AC_CHECK_LIBM' is obsolete.
configure.ac:107: You should run autoupdate.
aclocal.m4:3593: AC_CHECK_LIBM is expanded from...
configure.ac:107: the top level

I did as I was told:

$ autoupdate
$ autoconf -W all

I then reran configure, and the error from __arm__ being undefined is gone, but 
the Syntax error problem is still there.

I had previously established that running ./configure with no options 
succeeded; I ran it again having defined CC and CPP to clang:
> configure:3060: checking build system type
> configure:3074: result: x86_64-apple-darwin13.0.2
> configure:3094: checking host system type
> configure:3107: result: x86_64-apple-darwin13.0.2
> configure:3182: checking for gcc
> configure:3209: result: 
> /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
> configure:3438: checking for C compiler version
> configure:3447: 
> /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
>  --version >&5
> Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
> Target: x86_64-apple-darwin13.0.2
> configure:4119: checking how to run the C preprocessor
> configure:4150: 
> /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
>  -E  conftest.c

This works. So maybe it’s not clang per se, but something it’s being fed. All 
very confusing. Still waiting for insight.


On Feb 3, 2014, at 6:30 PM, Patrick Alken <address@hidden> wrote:

> On 02/02/2014 07:48 PM, Peter Johansson wrote:
>> Either a bug i Autoconf or if one is
>> supposed to invoke ./configure is dome different way. I cannot tell and
>> it's probably a better to check with autoconf folks.
> Hi Peter, perhaps you could post your question to the autoconf list and let 
> us know their reply.

Attachment: smime.p7s
Description: S/MIME cryptographic signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]