[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #42029] insmod ahci clears all detected devices

From: benok
Subject: [bug #42029] insmod ahci clears all detected devices
Date: Sat, 05 Apr 2014 20:29:12 +0000
User-agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Follow-up Comment #4, bug #42029 (project grub):

Thanks about biosnum.
I tried to set biosnum like below, but no success :-(

In reference, https://www.gnu.org/software/grub/manual/html_node/biosnum.html

>When chain-loading another boot loader (see Chain-loading), 
>GRUB may need to know what BIOS drive number corresponds to 
>the root device (see root) so that it can set up registers properly.

So I searched "BIOS drive number" and got pages below.


I tried following sequence where XXXX=0x80, 0x81, 128, 129, 130, 0, 1, 2, but
failed to boot.
(0x81, 129 gives no error display and halt, other gives "boot error".)

grub> nativedisk 
error: no device connected. 
error: disk `hd0,gpt1' not found. 
error: disk `hd0,gpt1' not found. 
grub> ls 
(ahci3) (ahci2) (ahci1) (ahci0) (ahci0,msdos1) (ata0) (ata0,gpt3) 
(ata0,gpt2) (ata0,gpt1) (ata2) 
grub> set root=ahci0,msdos1 
grub> set biosnum=XXXX
grub> chainloader +1 
grub> boot 


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]