[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub failing ot install to mbr

From: Yan Seiner
Subject: Grub failing ot install to mbr
Date: Tue, 05 Feb 2008 05:13:46 -0800
User-agent: Icedove (X11/20071025)

I have a remotely administered machine that has lost its boot sector. This machine has worked fine for several years. We recently tried to update the kernel. On a reboot, the local sysadmin noticed some sort of error flash by on the screen, and now the machine won't boot. We can't seem to get grub back into the MBR.

We've created a grub floppy and reinstalled the stage 1, 1.5, and 2 loaders.

Now on reboot we're getting a message that says,

"Console redirect"

and the machine freezes.

As far as we know, console redirection is not enabled anywhere on the machine.

So.... Is it possible that grub used some random file rather than its stage 1 loader?

The machine has a boot partition, and we used

grub> find /grub/stage1


grub> root hd(0,0)
grub> setup hd(0)
grub> root hd(1,0)
grub> setup hd(1)

to install the bootloader on both RAID-1 mirrors. Grub installed everything without any errors.

Anyone have any suggestions?  I'm pretty stumped....


reply via email to

[Prev in Thread] Current Thread [Next in Thread]