[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Felix Miata
Subject: http://www.gnu.org/software/grub/manual/grub.html#Installing-GRUB-natively
Date: Sat, 07 Oct 2006 11:34:55 -0400
User-agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1) Gecko/20061006 SeaMonkey/1.1b

This section 3.2 makes no sense. When trying to install grub on a hd0 that
has only been partitioned, but has no OS installed, the partition to hold
kernels and stage1 and the rest of grub's files is empty. How can it find
/boot/grub/stage1 when it doesn't exist? Naturally it's not going to find
that file and get the error 15 when I do setup (hd0,0).

When trying to umount /dev/hdc3, where grub was long ago installed and
should not be disturbed, always the device is busy, so it's not possible to
remount the target on that apparently hard-coded location /boot/grub. On
'find /disks/hda1/grub/stage1', the actual target, error 15 again results.

I've booted from hd1 where Ubuntu is installed, and which has boots with
grub, but its /usr/lib has no directory named grub. Ubuntu puts its grub
files in /lib/grub, so section 3.1 also needs to be fixed to account for
optional installation locations.

When I tried following 3.3, using grub-install /dev/hda1 or grub-install
(hd0,0), the files were actually reinstalled to hd1/(hd1,2), and hd0 was
untouched. When I tried to install with the --root-directory=/disks/hda1
option, it created a boot directory containing a grub directory containing
the required files. This is makes no sense without further instruction that
linking /boot/grub to ../grub is required for /boot/grub to be where it
belongs when the device is actually mounted to the OS it is intended to start.
"The Lord is my strength and my shield; my heart trusts in him,
and I am helped."                               Psalm 28:7 NIV

 Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://mrmazda.no-ip.com/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]