[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #15611] pxegrub (patched), NVIDIA nForce4 SLI Gigabit ethernet cont

From: Tom Carpenter
Subject: [bug #15611] pxegrub (patched), NVIDIA nForce4 SLI Gigabit ethernet controller
Date: Thu, 2 Feb 2006 21:18:12 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050925 Firefox/1.0.4 (Debian package 1.0.4-2sarge5)


                 Summary: pxegrub (patched), NVIDIA nForce4 SLI Gigabit
ethernet controller
                 Project: GNU GRUB
            Submitted by: tomc
            Submitted on: Thu 02/02/06 at 21:18
                Category: Network
                Severity: Major
                Priority: 5 - Normal
              Item Group: Feature Request
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Tom Carpenter
        Originator Email: address@hidden
             Open/Closed: Open
                 Release: 0.97
         Reproducibility: Every Time
         Planned Release: 



I tried compiling grub 0.97, patched as mentioned here:


to try to provide (forcedeth) support for the gigabit controller on an Asus
A8N-SLI motherboard. PXE on the motherboard downloads and runs pxegrub, but
grub can't locate the ethernet controller, "Probing pci nic...failed". I also
tried compiling the patched grub with "--enable-pci-direct" - same results.
After looking at NVIDIA's documentation for this ethernet controller


(linked to from here: http://www.nvidia.com/page/pg_20041015215635.html)

I'm thinking that its not necessarily a problem with the driver for the
ethernet controller but rather grub's inability to probe the bus its on;
seems rather obvious given grub's "Probing pci nic...failed" message. Has
anyone found a solution to enable non-PCI ethernet controllers in pxegrub? I
realize this list is for Legacy Grub issues, but does anyone know if GRUB 2
will address this kind of problem? Does my uninformed theory about why grub
can't find the ethernet controller have any merit?

-Tom Carpenter
 UMASS - Amherst Dept of Biology


Carbon-Copy List:

CC Address                          | Comment
address@hidden                  | 


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]