[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #15611] pxegrub (patched), NVIDIA nForce4 SLI Gigabit ethernet

From: Scott Leerssen
Subject: Re: [bug #15611] pxegrub (patched), NVIDIA nForce4 SLI Gigabit ethernet controller
Date: Thu, 2 Feb 2006 17:24:10 -0500

I had the same problem booting IP over InfiniBand (IPoIB), and have two solutions. One is to embed a menu.lst file in nbgrub, so it doesn't have to make a second trip to get its configuration. This will allow you to select boot devices attached (like hard drives). If you want to boot something more clever, like an NFS root, you can use pxelinux and load an initrd, assuming it's linux that you want to run.

On Feb 2, 2006, at 4:18 PM, Tom Carpenter wrote:


                 Summary: pxegrub (patched), NVIDIA nForce4 SLI Gigabit
ethernet controller
                 Project: GNU GRUB
            Submitted by: tomc
            Submitted on: Thu 02/02/06 at 21:18
                Category: Network
                Severity: Major
                Priority: 5 - Normal
              Item Group: Feature Request
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Tom Carpenter
        Originator Email: address@hidden
             Open/Closed: Open
                 Release: 0.97
         Reproducibility: Every Time
         Planned Release:



I tried compiling grub 0.97, patched as mentioned here:


to try to provide (forcedeth) support for the gigabit controller on an Asus A8N-SLI motherboard. PXE on the motherboard downloads and runs pxegrub, but grub can't locate the ethernet controller, "Probing pci nic...failed". I also tried compiling the patched grub with "--enable-pci-direct" - same results.
After looking at NVIDIA's documentation for this ethernet controller


(linked to from here: http://www.nvidia.com/page/pg_20041015215635.html)

I'm thinking that its not necessarily a problem with the driver for the
ethernet controller but rather grub's inability to probe the bus its on; seems rather obvious given grub's "Probing pci nic...failed" message. Has anyone found a solution to enable non-PCI ethernet controllers in pxegrub? I realize this list is for Legacy Grub issues, but does anyone know if GRUB 2 will address this kind of problem? Does my uninformed theory about why grub
can't find the ethernet controller have any merit?

-Tom Carpenter
 UMASS - Amherst Dept of Biology


Carbon-Copy List:

CC Address                          | Comment
address@hidden                  |


Reply to this item at:


  Message sent via/by Savannah

Bug-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]