[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#44506: 28.0.50; Segfault on opening a particular message in Gnus in

From: Amin Bandali
Subject: bug#44506: 28.0.50; Segfault on opening a particular message in Gnus in terminal/tty
Date: Fri, 13 Nov 2020 00:20:16 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Eli Zaretskii writes:

>> From: Eric Abrahamsen <eric@ericabrahamsen.net>
>> Cc: bandali@gnu.org,  44506@debbugs.gnu.org
>> Date: Mon, 09 Nov 2020 21:48:10 -0800
>> I've tried today to come up with a recipe that doesn't involve
>> installing EBDB, but so far have failed. I tried edebugging the various
>> message-displaying functions to see exactly what was causing the bug,
>> but got no segfault so long as the functions were instrumented.
>> Basically EBDB attaches a hook to `gnus-article-prepare-hook', which
>> uses `gnus-fetch-original-field' to pull some data out of the article,
>> looks for records that match that data, and displays the records.
>> With "emacs -Q" there are no records to search or display, so I assumed
>> it must be the header-access functions causing the problem. But I wrote
>> a function that does most of what EBDB does, without actually using
>> EBDB, and it caused no segfault, so I don't know what's going on there,
>> sorry.
> Thank you for your efforts.

I, too, would like to say thank you, both to Eli and Eric, for your
efforts and looking into this.  I just sent information to Eli off-list
for accessing a test account I set up on a server of mine for debugging
this issue.

Thanks again.

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]