[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#44506: 28.0.50; Segfault on opening a particular message in Gnus in

From: Eric Abrahamsen
Subject: bug#44506: 28.0.50; Segfault on opening a particular message in Gnus in terminal/tty
Date: Mon, 09 Nov 2020 21:48:10 -0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Eli Zaretskii <eliz@gnu.org> writes:

>> Date: Mon, 09 Nov 2020 09:04:58 +0200
>> From: Eli Zaretskii <eliz@gnu.org>
>> Cc: eric@ericabrahamsen.net, 44506@debbugs.gnu.org
>> Thanks, but this seems to be from a different GDB session? The vpos
>> is 24 instead of 29 and the data of the glyph structure clearly
>> differs from what pgrowx displayed in your previous report? I need
>> consistent and coherent data from the same crash.
>> Or maybe you can come up with a reproduction recipe ? That'd really
>> make the debugging much more efficient...
> Alternatively, if you can give me an ssh login on that system, and set
> up an account for me so that I could reproduce the problem, I could
> debug it remotely on your system.

I've tried today to come up with a recipe that doesn't involve
installing EBDB, but so far have failed. I tried edebugging the various
message-displaying functions to see exactly what was causing the bug,
but got no segfault so long as the functions were instrumented.

Basically EBDB attaches a hook to `gnus-article-prepare-hook', which
uses `gnus-fetch-original-field' to pull some data out of the article,
looks for records that match that data, and displays the records.

With "emacs -Q" there are no records to search or display, so I assumed
it must be the header-access functions causing the problem. But I wrote
a function that does most of what EBDB does, without actually using
EBDB, and it caused no segfault, so I don't know what's going on there,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]