[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#44270: 24.5; EMMS failures while installing

From: Yoni Rabkin
Subject: bug#44270: 24.5; EMMS failures while installing
Date: Wed, 04 Nov 2020 21:38:19 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux)

Stefan Kangas <stefan@marxist.se> writes:

> Lars Ingebrigtsen <larsi@gnus.org> writes:
>> John Gilmore <gnu@toad.com> writes:
>>> M-x list-packages
>>> picked emms, hit Install.
>>> I've included the *Compile-Log* buffer contents, which include one
>>> error and several warnings.
>>> Compiling file /gnu/home/.emacs.d/elpa/emms-6.0/emms-browser.el at Tue Oct 
>>> 27 18:43:24 2020
>>> emms-browser.el:292:1:Error: Cannot open load file: no such file or 
>>> directory, seq
>> It seems like EMMS requires seq, but that it's not installed in your
>> Emacs?  My guess is that your Emacs (24.5) is too old to use EMMS.
>> But EMMS should specify that, I guess?
> Indeed, I think EMMS should add a dependency on seq:
>     ;; Package-Requires: ((cl-lib "0.5") (seq "2.22"))
> Perhaps it should add a dependency also on Emacs, but I don't know which
> version it would need.
> Yoni, could you please take a look at this?  This might warrant
> releasing a new version of the package on GNU ELPA.

The code which requires seq (in emms-browser.el) was added in 2017
(contemporaneous with Emacs 25.2), but of course Emacs 24.5 dates back
from 2015.

I'll see if it possible to re-write that code without seq and therefore
to regain that backward compatibility. If so, it will take a good while
before it is done.

Should I add a dependency on a particular version of Emacs in the

   "Cut your own wood and it will warm you twice"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]