bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#7918: [PATCH] cc-mode: only the first clause of a for-loop should be


From: Alan Mackenzie
Subject: bug#7918: [PATCH] cc-mode: only the first clause of a for-loop should be checked for declarations
Date: Mon, 3 Jul 2017 20:18:08 +0000
User-agent: Mutt/1.7.2 (2016-11-26)

Hello, Noam and Glenn.

On Mon, Jul 03, 2017 at 15:46:00 -0400, address@hidden wrote:
> Glenn Morris <address@hidden> writes:

> > address@hidden wrote:

> >>> Bug fixed in master branch.

> >> I can confirm it's fixed in master (I wonder why the bug was reopened,
> >> apparently automatically?)

> > Nothing gets reopened automatically. I agree that sometimes debbugs
> > doesn't report the details of control requests in an informative way.
> > In this case, the bug was reopened in May 2016 (by Alan, from internal
> > logs). You'd have to ask him why.

It was because the original "fix" for the bug slowed CC Mode's
fontification down by a factor of ~3.

> > http://lists.gnu.org/archive/html/emacs-bug-tracker/2016-05/msg00126.html

> Oh, I was looking at
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=7918;msg=32.  So all those
> "fake control message" things are just the original control request
> getting lost somehow?

> Ccing Alan, please reopen if I made a mistake by closing this.

This is strange.  I sent an email attempting to close the bug for a
second time on 2016-05-16.  This email was actually received and
acknowledged by debbugs.gnu.org.  But apparently the bug didn't get
closed.  Maybe sending mail to address@hidden only works the
first time around.

Anyway, it's fine for the bug finally to be marked closed.  Thanks.

-- 
Alan Mackenzie (Nuremberg, Germany).





reply via email to

[Prev in Thread] Current Thread [Next in Thread]