bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25084: 25.1.90 tarfile has files.el newer than files.elc


From: Phillip Lord
Subject: bug#25084: 25.1.90 tarfile has files.el newer than files.elc
Date: Wed, 07 Dec 2016 15:46:24 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

Nicolas Petton <address@hidden> writes:

> Glenn Morris <address@hidden> writes:
>
> Hi Glenn,
>
>> In the 25.1.90 tarball, files.el is newer than files.elc.
>> This ought to be impossible, if the tarfile was created from a
>> bootstrap.
>
> It was, but I might have pulled a commit after bootstrapping (Eli
> mentioned that reason to me, and while I don't remember doing that, it
> has to be the case).
>
>> It causes building to recompile files.el, which is harmless but should
>> not be needed in a release.
>
> Indeed.  I'll keep this bug report open until the next pretest.


Can we add something to the build that checks this before the tar step?

Phil





reply via email to

[Prev in Thread] Current Thread [Next in Thread]