bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#18512: 24.3.93; tramp persistency file: incompatible with old versio


From: David Reitter
Subject: bug#18512: 24.3.93; tramp persistency file: incompatible with old versions? Tramp won't start!
Date: Sun, 21 Sep 2014 18:54:47 -0400

On Sep 21, 2014, at 5:36 PM, Glenn Morris <address@hidden> wrote:

> David Reitter wrote:
> 
>> The lack of warning is not.  I pointed out what the bug is in my other
>> e-mail
> 
> user-emacs-directory is a constant. You should not have changed it.

You’re right, it’s a constant.  If you do have a constant for this, assuming 
that the file name is .emacs.d or similar in startup.el is obviously poor style.

I changed it because the home directory is not where applications should store 
files in the Mac OSX system.
Hiding the folder with a dot is helpful, because the directory does not show up 
in Finder.  Yet, the correct place for such files would be in 
~/Library/Preferences/Emacs/.
There is a special case for Windows, perhaps because the dot-filename syntax 
won’t work.

There are differences in philosophy between GNU Emacs and Aquamacs Emacs.  This 
may be one of them.









reply via email to

[Prev in Thread] Current Thread [Next in Thread]