bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#16382: Cut/Copy tool-bar icons issue


From: Angelo Graziosi
Subject: bug#16382: Cut/Copy tool-bar icons issue
Date: Tue, 14 Jan 2014 18:25:58 +0100
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Thunderbird/24.2.0

Il 14/01/2014 17.07, Jan Djärv ha scritto:
Hello.

14 jan 2014 kl. 10:03 skrev Angelo Graziosi <address@hidden>:

Should we open a new bug report for this?


This report is fine.  The omission to copy to PRIMARY looks intended, because 
when text is read-only and cut acts like copy, text is copied to PRIMARY.

"intended" ? If it is intended, which is its usefulness?

If one wants to move text from a place to another, this doesn't work using the mouse and the "cut" icon on the tool-bar...

1. select the text with mouse-1 (dragging over the text)
2. click the "cut" icon on the tool-bar: the text is removed
3. now move the mouse pointer where you want the text to reappear
4. click mouse-2 to paste: nothing happens

So, newly, which the usefulness of the above "intended" omission?


I wonder if there is some thought behind this we don't see.

ah..


Ciao,
Angelo.


Il 12/01/2014 19.03, Jan Djärv ha scritto:
Hello.

Copy does save in PRIMARY, but cut does not for some reason.

     Jan D.


2014-01-12 12:26, Angelo Graziosi skrev:
Il 09/01/2014 3.00, Stefan Monnier ha scritto:

I've installed a patch which calls force-mode-line-update when the mark
is (de)activated.

Hmm... it seems there are still problems, mainly with "cut" icon...

With a recent trunk build (GTK build on Cygwin, two days ago), I see
this:

$ emacs -Q &

1. Now with the mouse I select the word "create" on second row of scratch
buffer. The "cut" and "copy" icons in tool-bar are active.

2. I click the "cut" icon and the word "create" is removed and the
"cut" and
"copy" icons are grayed (disabled).

3. Then I move the mouse pointer on the letter "b" of the word
"buffer" on
third row and...

4. ...I click the mouse-2 (wheel) to paste.. but it doesn't work, only
the
cursor is moved over the "b".

The same happens if in step 3., after moving the mouse pointer, I
click with
mouse-1 to move the cursor over the "b" before step 4.


If I repeat all the above steps changing the "cut" icon with "copy"
icon, all
works as expected.


Ciao,
  Angelo.








reply via email to

[Prev in Thread] Current Thread [Next in Thread]