[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#8369: vc-annotate fails

From: Glenn Morris
Subject: bug#8369: vc-annotate fails
Date: Tue, 29 Mar 2011 13:58:29 -0400
User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)

[Please try not to use the newsgroup gateway for posting if you can.
It bypasses the bug tracker.]

Uwe Brauer wrote:

> Right, I tried it out also with GNU emacs 23.1 (that is the
> latest version in Kubuntu 10.1) with  Xemacs 21.4.22 and
> 21.5.29 and it failed in all of them.
> I then tried vc-annotate  with different rev version and
> indeed then I found a critical number such that it worked for
> all version below this number.
> I removed the version from the branch via rcs -orev and then
> vc-annotate worked again!
> BTW there is no emacs command for rcs -o?
> So I am not sure what to conclude, maybe I should contact
> directly the author of that function.

I suggest something like:

Make sure you have the .el files installed, if they come in a separate
package on your distribution. Then do:

emacs-23.1 -Q -l cl -l vc-rcs.el

C-h f vc-rcs-annotate-command

Click on `vc-rcs.el' link to go to definition.

M-x edebug-defun

Then repeat the thing that causes the error, stepping through the
vc-rcs-annotate-command with the space key.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]