[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3122: Error saving commit messages for bazaar (bzr).

From: Eli Zaretskii
Subject: bug#3122: Error saving commit messages for bazaar (bzr).
Date: Mon, 27 Apr 2009 21:25:16 +0300

> Date: Sun, 26 Apr 2009 22:52:45 -0700
> From: Novimir Pablant <address@hidden>
> Cc: address@hidden
> I installed Emacs- and tried reproducing the error.
> I still get the error, but now the file is saved anyway.  This is 
> certainly an improvement.
> Still using emacs23 I tried the two commands:
> M-: (file-readable-p 
> "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET
> Responds t
> M-: (insert-file-contents 
> "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET
> Gives the error (from the Backtrace):
> Debugger entered--Lisp error: (error "IO error reading 
> c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate: 
> Permission denied")

What does the following command produce?

  M-: (file-attributes
   "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

Also, what does the following display?

  M-: (user-real-login-name) RET

(I suspect that somehow this file was made unreadable for you,
i.e. private to another user.  Assuming you are on Windows XP, the
test in file-readable-p does not take into account Windows native
security settings enforced through ACLs.  So it could think the file
is readable by you, when it really isn't.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]