[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3122: Error saving commit messages for bazaar (bzr).

From: Novimir Pablant
Subject: bug#3122: Error saving commit messages for bazaar (bzr).
Date: Sun, 26 Apr 2009 22:52:45 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

I installed Emacs- and tried reproducing the error.

I still get the error, but now the file is saved anyway. This is certainly an improvement.

Still using emacs23 I tried the two commands:

M-: (file-readable-p "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

Responds t

M-: (insert-file-contents "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

Gives the error (from the Backtrace):
Debugger entered--Lisp error: (error "IO error reading c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate: Permission denied")

eval((insert-file-contents "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate")) eval-expression((insert-file-contents "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") nil)
  call-interactively(eval-expression nil nil)


On 4/26/2009 8:02 PM, Stefan Monnier wrote:
vc-bzr-registered: IO error reading
Permission denied

Bazaar version 1.13
Emacs version 22.3

Can you try and reproduce this bug with the Emacs-23 pretest?

Also, as far as I can tell, the code in vc-bzr.el (in Emacs-22.3 as
well as in the upcoming Emacs-23) checks (file-readable-p dirstate)
before reading the file, so could you check:

   M-: (file-readable-p 
"c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

to see if it indeed returns t rather than nil.  And then try

   M-: (insert-file-contents 
"c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

to check that it indeed signals the error you're seeing.

If indeed, file-readable-p claims the file is readable, but
insert-file-contents signals a "permission denied", then the problem
seems to be in the C code (or even deeper such that there's no way for
Emacs to predict that insert-file-contents will signal an error).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]