[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: large file support?

From: Greg Earle
Subject: Re: large file support?
Date: Sun, 12 Sep 2004 00:01:36 -0700

I was just searching the GNU "bug-fileutils" mailing list archives from
back in July and found a reference to what I was looking for:

I had stumbled upon the same problem as Joe Potenza did ("updatedb",
running GNU "find", was stumbling over > 4GB files) and tried the fix
(on Solaris 7) as described in Bob Proulx's post:


(I rebuilt "find" 4.1 with "-D_FILE_OFFSET_BITS=64" set in $CFLAGS.)

That solved my problem with the "Value too large for defined data
type" error, but unfortunately, it introduced a new one - the "-ls"
switch now returned "0" for all file/block sizes.

Then I noticed there's a findutils-4.1.20 on alpha.GNU.ORG, and so I
built that.  It fixes the > 4 GB file size problem and doesn't break
"-ls", so now I'm reasonably happy - except it looks like AFS support
has been pretty much deprecated.  Why is that?  (While find/fstype.c
still has the AFS support in it, "configure" has had all the stuff -
i.e., "--with-afs", and the additions to CPPFLAGS/LIBS if "--with-afs"
is given - ripped out of it, and there's no longer any section with
"#undef AFS" in acconfig.h/config.h.in anymore.)

(I also found if I wanted AFS support and used the "--with-afs" switch
 with "configure", I had to add "-lsocket -lnsl" to the LIBS definition
 in "configure" as the AFS stuff needs to link to the socket library -
 on Solaris 7, anyway - and it needs "gethostbyname" from "libnsl".)


        - Greg Earle

reply via email to

[Prev in Thread] Current Thread [Next in Thread]