[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-ddrescue] Input/output error

From: Chris Date
Subject: [Bug-ddrescue] Input/output error
Date: Thu, 27 Sep 2007 17:44:21 +0100

I'm trying to rescue some data from an external hard drive for a friend of mine.
It's quite urgent because she's a professional graphic artist and the files are
needed for a current job.  (She was unlucky because the drive containing the
originals died with a complete electrical/mechanical failure and the backup
drive, the one I now have, is inaccessible too.)

I've used ddrescue version 1.5 under Linux to copy the drive, 300Gb, to a 500Gb
external drive.  That took over a week, with a substantial amount of errors.  I
then tried to use the -r parameter to attempt to retrieve some of the missing
areas, but when I do so the process ends after about 15 minutes with
"Input/output error".  Can you suggest why this might be, and what I should try

Here is the output from a failed attempt using -r1:

address@hidden:~$ ddrescue -v -r1 /dev/sda /dev/sdb LaCieBackup.log

About to copy 327857 MBytes from /dev/sda to /dev/sdb
    Starting positions: infile = 0 B,  outfile = 0 B
    Copy block size: 128 hard blocks
Hard block size: 512 bytes
Max_retries: 1
Direct: no    Split: yes    Truncate: no

Press Ctrl-C to interrupt
Initial status (read from logfile)
rescued:   316308 MB,  errsize:  11549 MB,  errors: 22556805
Current status
rescued:   316308 MB,  errsize:  11549 MB,  current rate:        0 B/s
rescued:   316308 MB,  errsize:  11549 MB,  current rate:        0 B/ss
   ipos:   202782 MB,   errors: 22556781,    average rate:       41 B/s
   opos:   202782 MBr: Input/output error

Note that in this case the error count went down, indicating that some data had
been retrieved.  However, when I previously tried -r5 and -r2 there was no such

  Best wishes,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]