[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-ddrescue] Re: Input/output error

From: Chris Date
Subject: [Bug-ddrescue] Re: Input/output error
Date: Thu, 27 Sep 2007 18:16:10 +0100

As a follow up to my earlier message, I'm now confused about the difference
between the original drive and the copy.  The first entry in the ddrescue log
file is:

  0x00000000  0x262AE71000  +

That means that the first 163,928,543,232 bytes copied successfully, which
should contain the partition table.  However, when I run fdisk on the two drives
I get different results.

The original doesn't appear to have a readable partition table:
address@hidden:~$ fdisk -ul /dev/sda

Disk /dev/sda: 327.8 GB, 327857208832 bytes
255 heads, 63 sectors/track, 39859 cylinders, total 640346111 sectors
Units = sectors of 1 * 512 = 512 bytes

Disk /dev/sda doesn't contain a valid partition table

But the copy apparently does:
address@hidden:~$ fdisk -ul /dev/sdb

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63   976768064   488384001    7  HPFS/NTFS

However, I can't mount this second drive using type -t ntfs.

All suggestions welcome, particularly about why there is a difference between
the two.

  Best wishes,

>I'm trying to rescue some data from an external hard drive for a friend of 
>It's quite urgent because she's a professional graphic artist and the files are
>needed for a current job.  (She was unlucky because the drive containing the
>originals died with a complete electrical/mechanical failure and the backup
>drive, the one I now have, is inaccessible too.)
>I've used ddrescue version 1.5 under Linux to copy the drive, 300Gb, to a 500Gb
>external drive.  That took over a week, with a substantial amount of errors.  I
>then tried to use the -r parameter to attempt to retrieve some of the missing
>areas, but when I do so the process ends after about 15 minutes with
>"Input/output error".  Can you suggest why this might be, and what I should try
>Here is the output from a failed attempt using -r1:
>    --------------------------------
>address@hidden:~$ ddrescue -v -r1 /dev/sda /dev/sdb LaCieBackup.log
>About to copy 327857 MBytes from /dev/sda to /dev/sdb
>    Starting positions: infile = 0 B,  outfile = 0 B
>    Copy block size: 128 hard blocks
>Hard block size: 512 bytes
>Max_retries: 1
>Direct: no    Split: yes    Truncate: no
>Press Ctrl-C to interrupt
>Initial status (read from logfile)
>rescued:   316308 MB,  errsize:  11549 MB,  errors: 22556805
>Current status
>rescued:   316308 MB,  errsize:  11549 MB,  current rate:        0 B/s
>rescued:   316308 MB,  errsize:  11549 MB,  current rate:        0 B/ss
>   ipos:   202782 MB,   errors: 22556781,    average rate:       41 B/s
>   opos:   202782 MBr: Input/output error
>    --------------------------------
>Note that in this case the error count went down, indicating that some data had
>been retrieved.  However, when I previously tried -r5 and -r2 there was no such
>  Best wishes,
>  Chris

reply via email to

[Prev in Thread] Current Thread [Next in Thread]